summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-04-19 14:42:29 -0400
committerCraig Andrews <candrews@gentoo.org>2019-04-19 14:42:58 -0400
commit28efa0b57547e2784ae33d273b500fe4aab84e52 (patch)
treeec8f379daf28df9da007d1d2045a93f4535acd44 /net-analyzer/netdata/netdata-9999.ebuild
parentdev-python/m2crypto: amd64 stable wrt bug #679662 (diff)
downloadgentoo-28efa0b57547e2784ae33d273b500fe4aab84e52.tar.gz
gentoo-28efa0b57547e2784ae33d273b500fe4aab84e52.tar.bz2
gentoo-28efa0b57547e2784ae33d273b500fe4aab84e52.zip
net-analyzer/netdata: Make xen and cups plugins optional
Closes: https://bugs.gentoo.org/683838 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 59396a96cc0e..54d150969d3c 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 ipmi mysql nfacct nodejs postgres +python tor"
+IUSE="caps +compression cpu_flags_x86_sse2 cups ipmi mysql nfacct nodejs postgres +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -40,6 +40,7 @@ RDEPEND="
sys-apps/util-linux
virtual/awk
caps? ( sys-libs/libcap )
+ cups? ( net-print/cups )
compression? ( sys-libs/zlib )
ipmi? ( sys-libs/freeipmi )
nfacct? (
@@ -58,6 +59,10 @@ RDEPEND="
)
postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
tor? ( net-libs/stem[${PYTHON_USEDEP}] )
+ )
+ xen? (
+ app-emulation/xen-tools
+ dev-libs/yajl
)"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -85,8 +90,10 @@ src_configure() {
econf \
--localstatedir="${EPREFIX}"/var \
--with-user=${NETDATA_USER} \
+ $(use_enable cups plugin-cups) \
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
+ $(use_enable xen plugin-xenstat) \
$(use_enable cpu_flags_x86_sse2 x86-sse) \
$(use_with compression zlib)
}