summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2016-08-28 21:17:09 -0400
committerDavid Seifert <soap@gentoo.org>2016-09-02 22:47:23 +0200
commit59ef0b7eab4e17848a7e1a0810fc61fa48b86f6d (patch)
tree0b2e600e6709ee8145e19336b5f95fa1186c6ad7 /net-analyzer/netdata
parentnet-p2p/i2p: Remove old 0.9.25-r1 (diff)
downloadgentoo-59ef0b7eab4e17848a7e1a0810fc61fa48b86f6d.tar.gz
gentoo-59ef0b7eab4e17848a7e1a0810fc61fa48b86f6d.tar.bz2
gentoo-59ef0b7eab4e17848a7e1a0810fc61fa48b86f6d.zip
net-analyzer/netdata-1.3.0: version bump
Gentoo-bug: 592352 Closes: https://github.com/gentoo/gentoo/pull/2156 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/netdata')
-rw-r--r--net-analyzer/netdata/Manifest1
-rw-r--r--net-analyzer/netdata/netdata-1.3.0.ebuild95
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild22
3 files changed, 114 insertions, 4 deletions
diff --git a/net-analyzer/netdata/Manifest b/net-analyzer/netdata/Manifest
index d69d88a786de..454863c0777b 100644
--- a/net-analyzer/netdata/Manifest
+++ b/net-analyzer/netdata/Manifest
@@ -1 +1,2 @@
DIST netdata-1.2.0.tar.xz 1254000 SHA256 5c1ff3fe0501b654cd92dbba3fe4c0fc125736b58d604340f138df80fb1de1ce SHA512 0c43e89c7cb52a5dde2aec13b06496ffb70fcb1952cf74156bd4400f3520b4136a94b5390077a4e5e3278a8e175dcc14505a456efafec5fdf0759af4846e03f4 WHIRLPOOL 211fabbecfd4b0ffe8f6fb5dbdc28cf08a743c4544e29dd500187547107500c1b42a95677d8de746cce367d4a59c17ff29328c47b0de65208004e6de65d63277
+DIST netdata-1.3.0.tar.xz 1647708 SHA256 bad5d259467ae42ceb0cf5f03fc4b37d094a81f21a772477e6ccc5b8a778bf15 SHA512 0e96f12cbeb7aeecb07b885a0f10940022741633e5cfd76d9f79c9efe3bce2583d96ae18995831fc48d6724f65357929dc5a4220521230ecfb8517f15e779217 WHIRLPOOL 85b87fc6ec76a0255732613606fd4d3000870252c84dbd7be51a2b0132d4d1875d38b61085daeb3ea4e31e522b5e86e05bacf3eb57895ca718cd58501b995955
diff --git a/net-analyzer/netdata/netdata-1.3.0.ebuild b/net-analyzer/netdata/netdata-1.3.0.ebuild
new file mode 100644
index 000000000000..f5951ec7e162
--- /dev/null
+++ b/net-analyzer/netdata/netdata-1.3.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit fcaps linux-info python-r1 systemd user
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/firehol/${PN}.git"
+ inherit git-r3 autotools
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://firehol.org/download/${PN}/releases/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Linux real time system monitoring, done right!"
+HOMEPAGE="https://github.com/firehol/netdata https://my-netdata.io/"
+
+LICENSE="GPL-3+ MIT BSD"
+SLOT="0"
+IUSE="+compression mysql nfacct nodejs +python"
+REQUIRED_USE="
+ mysql? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+# most unconditional dependencies are for plugins.d/charts.d.plugin:
+RDEPEND="
+ >=app-shells/bash-4:0
+ net-misc/curl
+ net-misc/wget
+ virtual/awk
+ net-libs/libmnl
+ || ( net-analyzer/netcat6 net-analyzer/netcat )
+ net-analyzer/tcpdump
+ net-analyzer/traceroute
+ compression? ( sys-libs/zlib )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ mysql? (
+ || ( dev-python/mysqlclient[${PYTHON_USEDEP}] dev-python/mysql-python[${PYTHON_USEDEP}] )
+ )
+ )
+ nfacct? (
+ net-firewall/nfacct
+ net-libs/libmnl
+ )
+ nodejs? (
+ net-libs/nodejs
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+: ${NETDATA_USER:=netdata}
+: ${NETDATA_GROUP:=netdata}
+
+FILECAPS=(
+ 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 / ${PN}
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-user=${NETDATA_USER} \
+ $(use_enable nfacct plugin-nfacct) \
+ $(use_with compression zlib)
+}
+
+src_install() {
+ default
+
+ fowners ${NETDATA_USER}:${NETDATA_GROUP} /var/log/netdata
+ fowners ${NETDATA_USER}:${NETDATA_GROUP} /var/cache/netdata
+
+ fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /usr/share/${PN}
+
+ newinitd system/netdata-openrc ${PN}
+ systemd_dounit system/netdata.service
+}
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index ad8fb3303138..f5951ec7e162 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -3,8 +3,9 @@
# $Id$
EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit linux-info systemd user fcaps
+inherit fcaps linux-info python-r1 systemd user
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/firehol/${PN}.git"
@@ -21,15 +22,28 @@ HOMEPAGE="https://github.com/firehol/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="+compression nfacct nodejs"
-
+IUSE="+compression mysql nfacct nodejs +python"
+REQUIRED_USE="
+ mysql? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# most unconditional dependencies are for plugins.d/charts.d.plugin:
RDEPEND="
>=app-shells/bash-4:0
net-misc/curl
net-misc/wget
virtual/awk
+ net-libs/libmnl
+ || ( net-analyzer/netcat6 net-analyzer/netcat )
+ net-analyzer/tcpdump
+ net-analyzer/traceroute
compression? ( sys-libs/zlib )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ mysql? (
+ || ( dev-python/mysqlclient[${PYTHON_USEDEP}] dev-python/mysql-python[${PYTHON_USEDEP}] )
+ )
+ )
nfacct? (
net-firewall/nfacct
net-libs/libmnl
@@ -74,7 +88,7 @@ src_install() {
fowners ${NETDATA_USER}:${NETDATA_GROUP} /var/log/netdata
fowners ${NETDATA_USER}:${NETDATA_GROUP} /var/cache/netdata
- chown -Rc ${NETDATA_USER}:${NETDATA_GROUP} "${ED}"/usr/share/${PN} || die
+ fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /usr/share/${PN}
newinitd system/netdata-openrc ${PN}
systemd_dounit system/netdata.service