summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-28 14:05:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-03-28 14:05:22 +0200
commit627d0ecb08c6cf0031287ad317334733d8c4be36 (patch)
tree85a745b852c06965914acce551d130a2b0e0582a /net-analyzer/nethogs/nethogs-0.8.5-r1.ebuild
parentdev-java/appframework: clean up old. (diff)
downloadgentoo-627d0ecb08c6cf0031287ad317334733d8c4be36.tar.gz
gentoo-627d0ecb08c6cf0031287ad317334733d8c4be36.tar.bz2
gentoo-627d0ecb08c6cf0031287ad317334733d8c4be36.zip
net-analyzer/nethogs: Revbump to not install into /usr/local (bug #614144).
Thanks to Daniel Augustin for the bug report and the hint how to fix it. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.8.5-r1.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.8.5-r1.ebuild b/net-analyzer/nethogs/nethogs-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..96e845c300c7
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="https://github.com/raboof/nethogs"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC CXX
+ emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )" ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="/usr" install
+ dodoc Changelog DESIGN README.decpcap.txt README.md
+}