summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-25 18:36:23 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-25 18:40:31 +0200
commit711e19ade6d70c3b33b175580560bdef1d1b8726 (patch)
tree849f1559959bc6e11690370d37d920ca46e2a76b /net-analyzer/netio/netio-1.33.ebuild
parentdev-db/sqlite: Stabilize 3.33.0 arm64, #738220 (diff)
downloadgentoo-711e19ade6d70c3b33b175580560bdef1d1b8726.tar.gz
gentoo-711e19ade6d70c3b33b175580560bdef1d1b8726.tar.bz2
gentoo-711e19ade6d70c3b33b175580560bdef1d1b8726.zip
net-analyzer/netio: Version 1.33
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Closes: https://bugs.gentoo.org/731196 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/netio/netio-1.33.ebuild')
-rw-r--r--net-analyzer/netio/netio-1.33.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/netio/netio-1.33.ebuild b/net-analyzer/netio/netio-1.33.ebuild
new file mode 100644
index 000000000000..b1b367dca376
--- /dev/null
+++ b/net-analyzer/netio/netio-1.33.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit edos2unix toolchain-funcs
+
+DESCRIPTION="Network benchmark using TCP and UDP protocols"
+HOMEPAGE="https://web.ars.de/netio/"
+SRC_URI="https://www.ars.de/${PN}${PV/.}.zip"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+RESTRICT="mirror" # bug #391789 comment #1
+
+DEPEND="
+ app-arch/unzip
+ >=sys-apps/sed-4
+"
+S=${WORKDIR}
+
+src_prepare() {
+ edos2unix *.c *.h *.doc
+
+ default
+
+ sed -i \
+ -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
+ -e 's|\(CC\)=|\1?=|g' \
+ -e 's|\(CFLAGS\)=|\1+=|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ linux
+}
+
+src_install() {
+ dobin netio
+ dodoc netio.doc
+}