summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-12 17:47:35 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-12 17:48:36 -0600
commite548587eae35e75a7d9bce719571714df6ca066b (patch)
tree5b633933303694db19a15b8dc6905db0dc80360b /net-analyzer/netpipe/netpipe-3.7.2.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.9.3 (diff)
downloadgentoo-e548587eae35e75a7d9bce719571714df6ca066b.tar.gz
gentoo-e548587eae35e75a7d9bce719571714df6ca066b.tar.bz2
gentoo-e548587eae35e75a7d9bce719571714df6ca066b.zip
net-analyzer/netpipe: new package
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer/netpipe/netpipe-3.7.2.ebuild')
-rw-r--r--net-analyzer/netpipe/netpipe-3.7.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/netpipe/netpipe-3.7.2.ebuild b/net-analyzer/netpipe/netpipe-3.7.2.ebuild
new file mode 100644
index 000000000000..afe44ceeee72
--- /dev/null
+++ b/net-analyzer/netpipe/netpipe-3.7.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_PN=NetPIPE
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="network protocol independent performance evaluator"
+HOMEPAGE="http://bitspjoule.org/netpipe/"
+SRC_URI="http://bitspjoule.org/netpipe/code/${MY_P}.tar.gz"
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ipv6"
+
+DOCS=(
+ bin/feplot
+ bin/geplot
+ bin/nplaunch
+ dox/README
+ dox/netpipe_paper.ps
+ dox/np_cluster2002.pdf
+ dox/np_euro.pdf
+ )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-makefile.patch
+ )
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" memcpy tcp $(usex ipv6 tcp6 '')
+}
+
+src_install() {
+ dobin NPmemcpy NPtcp
+ use ipv6 && dobin NPtcp6
+ doman dox/netpipe.1
+ einstalldocs
+}