summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/netsniff-ng/netsniff-ng-0.5.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/netsniff-ng/netsniff-ng-0.5.8.ebuild')
-rw-r--r--net-analyzer/netsniff-ng/netsniff-ng-0.5.8.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/netsniff-ng/netsniff-ng-0.5.8.ebuild b/net-analyzer/netsniff-ng/netsniff-ng-0.5.8.ebuild
new file mode 100644
index 000000000000..b0b64f8c3739
--- /dev/null
+++ b/net-analyzer/netsniff-ng/netsniff-ng-0.5.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="high performance network sniffer for packet inspection"
+HOMEPAGE="http://netsniff-ng.org/"
+MY_P=${P/_rc/-rc}
+SRC_URI="http://pub.${PN}.org/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/geoip
+ dev-libs/libcli
+ dev-libs/libnl:3
+ dev-libs/userspace-rcu
+ net-libs/libnet:1.1
+ net-libs/libnetfilter_conntrack
+ net-libs/libpcap
+ sys-libs/ncurses:5
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ =net-libs/nacl-0_p20110221*
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e '/CFLAGS/s:?=:+=:' \
+ -e '/CFLAGS/s:\(-g\|-O2\|-O3\|-m\(arch\|tune\)=native\)::g' \
+ -i Makefile || die
+
+ if ! grep nacl-20110221 curvetun/nacl_build.sh >/dev/null ; then
+ die "have nacl-20110221, expected $(grep ${MY_NACL_P} curvetun/nacl_build.sh)"
+ fi
+
+ export NACL_INC_DIR="${EROOT}usr/include/nacl"
+ export NACL_LIB_DIR="${EROOT}usr/$(get_libdir)/nacl"
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getCC)" CCACHE="" \
+ LEX=lex YAAC=bison STRIP=@true \
+ Q= HARDENING=1
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" ETCDIR="${ED}etc" install
+
+ dodoc AUTHORS README REPORTING-BUGS
+}