summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 23:56:52 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-29 00:17:55 -0400
commitdb4f8ee1388f94047d29a8319885196c9418eeab (patch)
treef92122963b9a0a04e53ad5d99d3b656e3d8bf187 /net-analyzer/nettop/nettop-0.2.3-r2.ebuild
parentnet-analyzer/pathload: fix configure with clang (diff)
downloadgentoo-db4f8ee1388f94047d29a8319885196c9418eeab.tar.gz
gentoo-db4f8ee1388f94047d29a8319885196c9418eeab.tar.bz2
gentoo-db4f8ee1388f94047d29a8319885196c9418eeab.zip
net-analyzer/nettop: EAPI7->8, tidy a bit
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-analyzer/nettop/nettop-0.2.3-r2.ebuild')
-rw-r--r--net-analyzer/nettop/nettop-0.2.3-r2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/nettop/nettop-0.2.3-r2.ebuild b/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
index a42bab62df49..f135facf4384 100644
--- a/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
+++ b/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
@@ -1,23 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="top-like program for network activity"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc x86"
-DEPEND="
+RDEPEND="
sys-libs/slang
- net-libs/libpcap
-"
-RDEPEND="${DEPEND}"
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gcc411.patch
@@ -26,10 +25,11 @@ PATCHES=(
src_prepare() {
default
+
tc-export CC
}
src_install() {
dosbin nettop
- dodoc ChangeLog README THANKS
+ einstalldocs
}