summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-24 13:50:00 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-24 13:50:33 +0100
commiteba0e3a0dd9ac6ffc9a1ceae51822d65145a0cfb (patch)
tree312f514d2b5d229b338d34319c817d2a00a3fd33 /net-analyzer/nmap
parentnet-analyzer/wireshark: Add USE=androiddump. Add USE=tfshark. (diff)
downloadgentoo-eba0e3a0dd9ac6ffc9a1ceae51822d65145a0cfb.tar.gz
gentoo-eba0e3a0dd9ac6ffc9a1ceae51822d65145a0cfb.tar.bz2
gentoo-eba0e3a0dd9ac6ffc9a1ceae51822d65145a0cfb.zip
net-analyzer/nmap: Make makefile.dep. Do not remove targets.
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/nmap-7.01.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-7.01.ebuild b/net-analyzer/nmap/nmap-7.01.ebuild
index 0022291860af..dd19efc9d733 100644
--- a/net-analyzer/nmap/nmap-7.01.ebuild
+++ b/net-analyzer/nmap/nmap-7.01.ebuild
@@ -96,6 +96,11 @@ src_prepare() {
-e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
Makefile.in || die
+ sed -i \
+ -e '/rm -f $@/d' \
+ $(find . -name Makefile.in) \
+ || die
+
# Fix desktop files wrt bug #432714
sed -i \
-e '/^Encoding/d' \
@@ -126,6 +131,11 @@ src_configure() {
}
src_compile() {
+ local directory
+ for directory in . libnetutil ncat nmap-update nping nsock/src; do
+ emake -C "${directory}" makefile.dep
+ done
+
emake \
AR=$(tc-getAR) \
RANLIB=$(tc-getRANLIB)