summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-05-13 17:10:32 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-05-13 17:11:06 +0900
commite25f018e70d3ac9a16cd8de46497dbb1e6f22965 (patch)
tree3d2faacfe2d7905d65a69f6132efc2b907269205 /net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
parentdev-util/include-what-you-use: drop old (diff)
downloadgentoo-e25f018e70d3ac9a16cd8de46497dbb1e6f22965.tar.gz
gentoo-e25f018e70d3ac9a16cd8de46497dbb1e6f22965.tar.bz2
gentoo-e25f018e70d3ac9a16cd8de46497dbb1e6f22965.zip
net-analyzer/openbsd-netcat: bump to OpenBSD cvs version 1.105.
Import patches from Debian. Package-Manager: portage-2.2.28
Diffstat (limited to 'net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild')
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
new file mode 100644
index 000000000000..0aba3843a9da
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="the OpenBSD network swiss army knife"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/"
+SRC_URI="http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-7.debian.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libbsd"
+
+S=${WORKDIR}/netcat-openbsd-${PV}
+
+PATCHES=( "${WORKDIR}/debian/patches" )
+
+src_install() {
+ # avoid name conflict against net-analyzer/netcat
+ newbin nc nc.openbsd
+ newman nc.1 nc.openbsd.1
+ cd "${WORKDIR}/debian"
+ newdoc netcat-openbsd.README.Debian README
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ if [[ ${KERNEL} = "linux" ]]; then
+ ewarn "FO_REUSEPORT is introduced in linux 3.9. If your running kernel is older"
+ ewarn "and kernel header is newer, nc will not listen correctly. Matching the header"
+ ewarn "to the running kernel will do. See bug #490246 for details."
+ fi
+}