summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXiami <i@f2light.com>2018-09-06 19:19:39 +0800
committerBenda Xu <heroxbd@gentoo.org>2018-09-12 10:37:30 +0800
commitc0817e0ba61968f842f4f8d5fbb30d5c93be8dec (patch)
treeabde83aff34216bfe4d8e2969dd728b26ce106ee /net-analyzer/openbsd-netcat/openbsd-netcat-1.190.ebuild
parentwww-client/chromium: dev channel bump (70.0.3538.9) (diff)
downloadgentoo-c0817e0ba61968f842f4f8d5fbb30d5c93be8dec.tar.gz
gentoo-c0817e0ba61968f842f4f8d5fbb30d5c93be8dec.tar.bz2
gentoo-c0817e0ba61968f842f4f8d5fbb30d5c93be8dec.zip
net-analyzer/openbsd-netcat: bump to version 1.190
Bump to EAPI 7 (deprecate epatch) Use debian/patches/series to determine patch order Remove eapi-deprecated ebuild Closes: https://github.com/gentoo/gentoo/pull/9790 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/openbsd-netcat/openbsd-netcat-1.190.ebuild')
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.190.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.190.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.190.ebuild
new file mode 100644
index 000000000000..e94c5c4103ae
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.190.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="The OpenBSD network swiss army knife"
+HOMEPAGE="https://cvsweb.openbsd.org/src/usr.bin/nc/
+ https://salsa.debian.org/debian/netcat-openbsd"
+SRC_URI="http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-2.debian.tar.xz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="elibc_Darwin"
+
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="!elibc_Darwin? ( dev-libs/libbsd )
+ !net-analyzer/netcat
+ !net-analyzer/netcat6
+"
+
+S=${WORKDIR}/netcat-openbsd-${PV}
+
+src_prepare() {
+ for i_patch in $(<"${WORKDIR}"/debian/patches/series); do
+ eapply "${WORKDIR}"/debian/patches/"${i_patch}"
+ done
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # this undoes some of the Debian/Linux changes
+ eapply "${FILESDIR}"/${P}-darwin.patch
+ fi
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin nc
+ doman nc.1
+ cd "${WORKDIR}"/debian || die
+ newdoc netcat-openbsd.README.Debian README
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ if [[ ${KERNEL} = "linux" ]]; then
+ ewarn "SO_REUSEPORT is introduced in linux 3.9. If your running kernel is older"
+ ewarn "and kernel header is newer, nc will not listen correctly. Matching the header"
+ ewarn "to the running kernel will do. See bug #490246 for details."
+ fi
+}