summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-18 16:38:30 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-18 16:41:37 +0100
commit5aa79c96a0ab717f3d8783fab5644fea1624e2ea (patch)
tree1ddc52ce05e2e2d1d84df6d31b15ab4dbd808fd7 /net-analyzer/openvas-cli/openvas-cli-1.4.3.ebuild
parentnet-analyzer/openvas: Version Bump (diff)
downloadgentoo-5aa79c96a0ab717f3d8783fab5644fea1624e2ea.tar.gz
gentoo-5aa79c96a0ab717f3d8783fab5644fea1624e2ea.tar.bz2
gentoo-5aa79c96a0ab717f3d8783fab5644fea1624e2ea.zip
net-analyzer/openvas-cli: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-analyzer/openvas-cli/openvas-cli-1.4.3.ebuild')
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.4.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.4.3.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.4.3.ebuild
new file mode 100644
index 000000000000..670d169ebb1a
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=2209
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-8.0.4
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_beta/+beta}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}