summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-18 16:28:26 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-18 16:41:37 +0100
commitd91c938896457ce366ea399bb79a809b56fecb36 (patch)
tree3b12793ebc9ac44d56cc5a47ae41f66e1cce2f34 /net-analyzer/openvas-libraries/files
parentdev-python/lxml: Drop unused local USE-description: 'beautifulsoup3' (diff)
downloadgentoo-d91c938896457ce366ea399bb79a809b56fecb36.tar.gz
gentoo-d91c938896457ce366ea399bb79a809b56fecb36.tar.bz2
gentoo-d91c938896457ce366ea399bb79a809b56fecb36.zip
net-analyzer/openvas-libraries: Version Bump
fixes gnutls-3 support and compilation problems Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=544664 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=555544 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=556788 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-analyzer/openvas-libraries/files')
-rw-r--r--net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch b/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch
new file mode 100644
index 000000000000..3bd1208b55a7
--- /dev/null
+++ b/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch
@@ -0,0 +1,39 @@
+ base/CMakeLists.txt | 4 ++--
+ misc/CMakeLists.txt | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
+index 07febee..512e813 100644
+--- a/base/CMakeLists.txt
++++ b/base/CMakeLists.txt
+@@ -73,7 +73,7 @@ if (BUILD_SHARED)
+ assuan libgpg-error ole32 ws2_32 ffi z shlwapi dnsapi winmm)
+ target_link_libraries (openvas_base_shared openvas_omp_shared ${W32LIBS})
+ else (MINGW)
+- target_link_libraries (openvas_base_shared openvas_omp_shared ${GLIB_LDFLAGS} ${GIO_LDFLAGS} ${GNUTLS_LDFLAGS} ${ZLIB_LDFLAGS} ${GPGME_LDFLAGS})
++ target_link_libraries (openvas_base_shared openvas_omp_shared ${LIBSSH_LDFLAGS} ${GLIB_LDFLAGS} ${GIO_LDFLAGS} ${GNUTLS_LDFLAGS} ${ZLIB_LDFLAGS} ${GPGME_LDFLAGS})
+ endif (MINGW)
+ endif (BUILD_SHARED)
+
+@@ -89,7 +89,7 @@ add_custom_indent_targets (${FILES})
+ # TODO: This is currently only built for BUILD_SHARED
+ if (BUILD_SHARED)
+ add_executable (test-hosts test-hosts.c)
+- target_link_libraries (test-hosts openvas_base_shared ${GNUTLS_LDFLAGS} openvas_misc_shared ${GLIB_LDFLAGS})
++ target_link_libraries (test-hosts openvas_base_shared ${GNUTLS_LDFLAGS} openvas_misc_shared openvas_omp_shared ${GLIB_LDFLAGS})
+ endif (BUILD_SHARED)
+
+ ## Install
+diff --git a/misc/CMakeLists.txt b/misc/CMakeLists.txt
+index 7aaca2c..e7a0870 100644
+--- a/misc/CMakeLists.txt
++++ b/misc/CMakeLists.txt
+@@ -126,7 +126,7 @@ if (BUILD_SHARED)
+ else (MINGW)
+ target_link_libraries (openvas_misc_shared ${GNUTLS_LDFLAGS} openvas_base_shared ${UUID_LDFLAGS}
+ ${PCAP_LDFLAGS} ${LIBSSH_LDFLAGS} ${LDAP_LDFLAGS}
+- ${REDIS_LDFLAGS} ${GCRYPT_LDFLAGS})
++ ${GLIB_LDFLAGS} ${REDIS_LDFLAGS} ${GCRYPT_LDFLAGS})
+ endif (MINGW)
+ endif (BUILD_SHARED)
+