summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-07 09:54:02 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-07 09:58:45 +0100
commitda4cfd3f4e9d8dbd9c1bd0ad399259c8c238a219 (patch)
treeebcec105918cb4811b712004d0586bb99a4fada5 /net-analyzer/openvas/openvas-8.0.5-r1.ebuild
parentnet-analyzer/openvas-manager: Add missing redis dep (diff)
downloadgentoo-da4cfd3f4e9d8dbd9c1bd0ad399259c8c238a219.tar.gz
gentoo-da4cfd3f4e9d8dbd9c1bd0ad399259c8c238a219.tar.bz2
gentoo-da4cfd3f4e9d8dbd9c1bd0ad399259c8c238a219.zip
net-analyzer/openvas: Add missing redis dep
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567194 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-analyzer/openvas/openvas-8.0.5-r1.ebuild')
-rw-r--r--net-analyzer/openvas/openvas-8.0.5-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/openvas/openvas-8.0.5-r1.ebuild b/net-analyzer/openvas/openvas-8.0.5-r1.ebuild
new file mode 100644
index 000000000000..921963be24db
--- /dev/null
+++ b/net-analyzer/openvas/openvas-8.0.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf"
+
+RDEPEND="
+ dev-db/redis
+ >=net-analyzer/openvas-libraries-8.0.5
+ >=net-analyzer/openvas-scanner-5.0.4
+ >=net-analyzer/openvas-manager-6.0.6
+ >=net-analyzer/openvas-cli-1.4.3
+ net-analyzer/openvas-tools
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+ optfeature "The Greenbone Security Assistant as alternative to the plain scanner" net-analyzer/greebone-security-assistant
+}