summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2020-06-29 17:25:58 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-14 15:57:05 +0300
commit60eea14875dd8ace5c7f5a1d5f05021a46aed738 (patch)
treee6053a70698b2f43cf59599d3abb1cc62d4851ca /net-analyzer/ospd/ospd-2.0.1.ebuild
parentnet-analyzer/python-gvm: Version bump to 1.5.0 (diff)
downloadgentoo-60eea14875dd8ace5c7f5a1d5f05021a46aed738.tar.gz
gentoo-60eea14875dd8ace5c7f5a1d5f05021a46aed738.tar.bz2
gentoo-60eea14875dd8ace5c7f5a1d5f05021a46aed738.zip
net-analyzer/ospd: Version bump to 2.0.1
Closes: https://bugs.gentoo.org/725894 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/ospd/ospd-2.0.1.ebuild')
-rw-r--r--net-analyzer/ospd/ospd-2.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/ospd/ospd-2.0.1.ebuild b/net-analyzer/ospd/ospd-2.0.1.ebuild
new file mode 100644
index 000000000000..da7709abcf99
--- /dev/null
+++ b/net-analyzer/ospd/ospd-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ if use extras; then
+ bash "${S}"/doc/generate || die
+ HTML_DOCS=( "${S}"/doc/. )
+ fi
+ distutils-r1_python_compile
+}