summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/pnp4nagios/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/pnp4nagios/files')
-rw-r--r--net-analyzer/pnp4nagios/files/98_pnp4nagios-2.4.conf29
-rw-r--r--net-analyzer/pnp4nagios/files/98_pnp4nagios.conf22
-rw-r--r--net-analyzer/pnp4nagios/files/npcd37
-rw-r--r--net-analyzer/pnp4nagios/files/npcd.initd19
-rw-r--r--net-analyzer/pnp4nagios/files/pnp4nagios-0.6.14-makefile.patch32
5 files changed, 139 insertions, 0 deletions
diff --git a/net-analyzer/pnp4nagios/files/98_pnp4nagios-2.4.conf b/net-analyzer/pnp4nagios/files/98_pnp4nagios-2.4.conf
new file mode 100644
index 000000000000..5944a2e2f70f
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/98_pnp4nagios-2.4.conf
@@ -0,0 +1,29 @@
+<IfDefine PNP>
+
+ Alias /pnp4nagios /usr/share/pnp/
+
+ <Directory /usr/share/pnp>
+ AllowOverride AuthConfig
+ Require all granted
+
+ <IfModule rewrite_module>
+ # Turn on URL rewriting
+ RewriteEngine On
+ Options +FollowSymLinks
+
+ # Installation directory
+ RewriteBase /pnp4nagios
+
+ # Protect application and system files from being viewed
+ RewriteRule ^(application|modules|system) - [F,L]
+
+ # Allow any files or directories that exist to be displayed directly
+ RewriteCond %{REQUEST_FILENAME} !-f
+ RewriteCond %{REQUEST_FILENAME} !-d
+
+ # Rewrite all other URLs to index.php/URL
+ RewriteRule .* index.php/$0 [PT,L]
+ </IfModule>
+ </Directory>
+
+</IfDefine>
diff --git a/net-analyzer/pnp4nagios/files/98_pnp4nagios.conf b/net-analyzer/pnp4nagios/files/98_pnp4nagios.conf
new file mode 100644
index 000000000000..4879779a8f93
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/98_pnp4nagios.conf
@@ -0,0 +1,22 @@
+<IfDefine PNP>
+ Alias /pnp4nagios /usr/share/pnp/
+ <Directory /usr/share/pnp>
+ AllowOverride AuthConfig
+ Order allow,deny
+ Allow from all
+ <IfModule mod_rewrite.c>
+ # Turn on URL rewriting
+ RewriteEngine On
+ Options FollowSymLinks
+ # Installation directory
+ RewriteBase /pnp4nagios
+ # Protect application and system files from being viewed
+ RewriteRule ^(application|modules|system) - [F,L]
+ # Allow any files or directories that exist to be displayed directly
+ RewriteCond %{REQUEST_FILENAME} !-f
+ RewriteCond %{REQUEST_FILENAME} !-d
+ # Rewrite all other URLs to index.php/URL
+ RewriteRule .* index.php/$0 [PT,L]
+ </IfModule>
+ </Directory>
+</IfDefine>
diff --git a/net-analyzer/pnp4nagios/files/npcd b/net-analyzer/pnp4nagios/files/npcd
new file mode 100644
index 000000000000..3f0704043b39
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/npcd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+opts="${opts} reload"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting npcd"
+ start-stop-daemon --start --exec /usr/bin/npcd \
+ -- -f /etc/pnp/npcd.cfg \
+ -d
+ eend $? "Failed to Start npcd"
+}
+
+stop() {
+ ebegin "Stopping npcd"
+ start-stop-daemon --stop --quiet -n npcd
+ eend $? "Failed to Stop npcd"
+}
+
+reload() {
+ ebegin "Reloading npcd"
+ kill -HUP `pgrep npcd`
+ eend $? "Failed to reload npcd"
+}
+
+restart() {
+ ebegin "Restarting npcd"
+ svc_stop
+ svc_start
+ eend $? "Failed to Restart npcd"
+}
diff --git a/net-analyzer/pnp4nagios/files/npcd.initd b/net-analyzer/pnp4nagios/files/npcd.initd
new file mode 100644
index 000000000000..2c71ada44870
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/npcd.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+
+command="/usr/bin/npcd"
+command_args="-f /etc/pnp/npcd.cfg -d"
+
+depend() {
+ need net
+}
+
+reload() {
+ ebegin "Reloading npcd"
+ kill -HUP `pgrep npcd`
+ eend $? "Failed to reload npcd"
+}
diff --git a/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.14-makefile.patch b/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.14-makefile.patch
new file mode 100644
index 000000000000..469389d3ee31
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.14-makefile.patch
@@ -0,0 +1,32 @@
+diff -Naur pnp4nagios-0.6.14.orig/src/Makefile.in pnp4nagios-0.6.14/src/Makefile.in
+--- pnp4nagios-0.6.14.orig/src/Makefile.in 2011-08-10 17:18:46.000000000 +0200
++++ pnp4nagios-0.6.14/src/Makefile.in 2011-08-10 17:19:51.000000000 +0200
+@@ -83,7 +83,7 @@
+ #
+ ###############################
+ npcd: npcd.c $(NPCDOBJS) $(NPCDHEAD)
+- $(CC) $(CFLAGS) -o $@ npcd.c $(NPCDOBJS) -lpthread
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ npcd.c $(NPCDOBJS) -lpthread
+
+ ###############################
+ #
+@@ -118,7 +118,6 @@
+
+ install:
+ $(MAKE) install-basic
+- $(MAKE) strip-post-install
+
+ install-unstripped:
+ $(MAKE) install-basic
+diff -Naur pnp4nagios-0.6.14.orig/configure pnp4nagios-0.6.14/configure
+--- pnp4nagios-0.6.14.orig/configure 2011-08-12 09:01:12.000000000 +0200
++++ pnp4nagios-0.6.14/configure 2011-08-12 09:03:32.000000000 +0200
+@@ -5565,7 +5565,7 @@
+ PERFDATA_LOG="${localstatedir}/perfdata.log"
+ PERFDATA_DIR="${localstatedir}/perfdata"
+ PERFDATA_SPOOL_DIR="${localstatedir}/spool"
+- mandir="\${prefix}/man"
++ mandir="/usr/share/man"
+ ;;
+ esac
+