summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 03:17:54 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:55:07 +0100
commit965d93656a73d727e6cead17acc7e9eccb9098c2 (patch)
tree6e4b738788f75a7ca7e1af7f87b0ed31ae557808 /net-analyzer/portsentry/portsentry-1.2-r1.ebuild
parentnet-analyzer/pktstat: EAPI 7, eutils-- (diff)
downloadgentoo-965d93656a73d727e6cead17acc7e9eccb9098c2.tar.gz
gentoo-965d93656a73d727e6cead17acc7e9eccb9098c2.tar.bz2
gentoo-965d93656a73d727e6cead17acc7e9eccb9098c2.zip
net-analyzer/portsentry: EAPI 7, eutils--, non-Linux support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/portsentry/portsentry-1.2-r1.ebuild')
-rw-r--r--net-analyzer/portsentry/portsentry-1.2-r1.ebuild44
1 files changed, 33 insertions, 11 deletions
diff --git a/net-analyzer/portsentry/portsentry-1.2-r1.ebuild b/net-analyzer/portsentry/portsentry-1.2-r1.ebuild
index 29e14b375300..66dfae69b06a 100644
--- a/net-analyzer/portsentry/portsentry-1.2-r1.ebuild
+++ b/net-analyzer/portsentry/portsentry-1.2-r1.ebuild
@@ -1,29 +1,51 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Automated port scan detector and response tool"
# Seems like CISCO took the site down?
HOMEPAGE="https://sourceforge.net/projects/sentrytools/"
SRC_URI="mirror://sourceforge/sentrytools/${P}.tar.gz"
+S="${WORKDIR}"/${PN}_beta
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86"
+IUSE="kernel_Darwin kernel_linux kernel_FreeBSD kernel_SunOS"
-S="${WORKDIR}"/${PN}_beta
+RDEPEND="kernel_Darwin? ( app-shells/tcsh )"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-conf.patch
- epatch "${FILESDIR}"/${P}-config.h.patch
- epatch "${FILESDIR}"/${P}-gcc.patch
- epatch "${FILESDIR}"/${P}-ignore.csh.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-conf.patch
+ "${FILESDIR}"/${P}-config.h.patch
+ "${FILESDIR}"/${P}-gcc.patch
+ "${FILESDIR}"/${P}-ignore.csh.patch
+)
src_compile() {
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS} ${LDFLAGS}" linux
+ local target
+
+ if use kernel_Darwin ; then
+ target="osx"
+ elif use kernel_linux ; then
+ target="linux"
+ elif use kernel_FreeBSD ; then
+ target="freebsd"
+ elif use kernel_SunOS ; then
+ target="solaris"
+ fi
+
+ if [[ -z "${target}" ]] ; then
+ elog "Using 'generic' target for your platform"
+ target="generic"
+ else
+ elog "Using '${target}' (detected) target for your platform"
+ fi
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" "${target}"
}
src_install() {