summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-20 16:38:39 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-20 16:38:39 +0100
commit8aacb119165aa70974de8bb0547173d6960d85ba (patch)
treefa4bac8ef120cb7d4ea553386a5ae9391d12231b /net-analyzer/prometheus/prometheus-1.5.2.ebuild
parentdev-ml/ocaml-doc: remove old (diff)
downloadgentoo-8aacb119165aa70974de8bb0547173d6960d85ba.tar.gz
gentoo-8aacb119165aa70974de8bb0547173d6960d85ba.tar.bz2
gentoo-8aacb119165aa70974de8bb0547173d6960d85ba.zip
net-analyzer/prometheus: Version bump to 1.5.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-analyzer/prometheus/prometheus-1.5.2.ebuild')
-rw-r--r--net-analyzer/prometheus/prometheus-1.5.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/prometheus-1.5.2.ebuild b/net-analyzer/prometheus/prometheus-1.5.2.ebuild
new file mode 100644
index 000000000000..c9e69f93a6f6
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-1.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus/..."
+EGIT_COMMIT="v${PV}"
+PROMETHEUS_COMMIT="bd1182d"
+ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN%/*}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN%/*} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN%/*} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}