summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-19 16:22:22 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-19 16:22:22 +0100
commitb053419cb37ef5aea0134e2423a402f487d7c0de (patch)
tree5512e7c4f2b36a090fb77b96e45bf72b1aa08d9e /net-analyzer/prometheus
parentdev-libs/legousbtower: Mark all stable to satisfy current installs and repoman (diff)
downloadgentoo-b053419cb37ef5aea0134e2423a402f487d7c0de.tar.gz
gentoo-b053419cb37ef5aea0134e2423a402f487d7c0de.tar.bz2
gentoo-b053419cb37ef5aea0134e2423a402f487d7c0de.zip
net-analyzer/prometheus: Version bump to 2.1.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/prometheus')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.1.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index 3c632f55e07d..9c9a2d2d676e 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1 +1,2 @@
DIST prometheus-2.0.0.tar.gz 5603884 BLAKE2B 0e2c7ee267f4f817fe84105b89fa2951c07212ca75bf540c67afe900c1df62641919f2ad9d2ce24932a946a0c3db8da6847184c56578ef9626db1f55c1ea3080 SHA512 9d23e10b3eb12755781b9edc5c32a0cb1e99055a8a905517619d992a174a8621ebc1e82999ce2412e7fc3e2e0af8a0dfe1eded8bcd2701a5aaaffce79c7fbcc5
+DIST prometheus-2.1.0.tar.gz 5669858 BLAKE2B 96b9d7b1eb13017806cb2745cb874468a419550c7372aa8abada9d1a4e7fe386785f05abe8fd5681745db4a0c17260d5fde704a3b3ac5807107da0a935177264 SHA512 8adbbfcf6cf5b0bdd4a96f51f6c179c828d75a231b35f9ef40db6c07bcb8ffa6a3eb969b55a52ac70528ad5c8fe486be866db6ae174006220e0cfaa1da624346
diff --git a/net-analyzer/prometheus/prometheus-2.1.0.ebuild b/net-analyzer/prometheus/prometheus-2.1.0.ebuild
new file mode 100644
index 000000000000..f6d36b877433
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="85f23d8"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}