summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2021-03-18 23:22:31 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-22 15:33:55 +0200
commit3285b2b29823896dd52a131611366897c4220825 (patch)
treec2e1d45bf4bc2affcf6ae9fe72ff6a5965fb804e /net-analyzer/python-gvm/python-gvm-21.1.3.ebuild
parentnet-analyzer/greenbone-security-assistant: version bump to 20.8.1 (diff)
downloadgentoo-3285b2b29823896dd52a131611366897c4220825.tar.gz
gentoo-3285b2b29823896dd52a131611366897c4220825.tar.bz2
gentoo-3285b2b29823896dd52a131611366897c4220825.zip
net-analyzer/python-gvm: version bump to 21.1.3
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-21.1.3.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-21.1.3.ebuild b/net-analyzer/python-gvm/python-gvm-21.1.3.ebuild
new file mode 100644
index 000000000000..21cee4b94358
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-21.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest