summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-27 21:20:37 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-27 21:21:08 +0100
commitf3ca4afb08ee300c6d4202717844f82533db9ed3 (patch)
treeb65fc47bc2ae65b7ac7a1d55c3ee1d85faaa648d /net-analyzer/sarg/sarg-2.4.0.ebuild
parentx11-drivers/nvidia-drivers: Fix CFLAGS=-fno-common (diff)
downloadgentoo-f3ca4afb08ee300c6d4202717844f82533db9ed3.tar.gz
gentoo-f3ca4afb08ee300c6d4202717844f82533db9ed3.tar.bz2
gentoo-f3ca4afb08ee300c6d4202717844f82533db9ed3.zip
net-analyzer/sarg: Version 2.4.0
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Bug: https://bugs.gentoo.org/706748 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/sarg/sarg-2.4.0.ebuild')
-rw-r--r--net-analyzer/sarg/sarg-2.4.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/sarg/sarg-2.4.0.ebuild b/net-analyzer/sarg/sarg-2.4.0.ebuild
new file mode 100644
index 000000000000..6fbc48405afe
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="https://sourceforge.net/projects/sarg/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="bzip2 doublecheck +gd +glob ldap lzma pcre zlib"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ lzma? ( app-arch/xz-utils )
+ pcre? ( dev-libs/libpcre )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-config.patch
+ "${FILESDIR}"/${PN}-2.4.0-configure.patch
+ "${FILESDIR}"/${PN}-2.4.0-fabs.patch
+ "${FILESDIR}"/${PN}-2.4.0-format.patch
+)
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+ econf \
+ $(use_enable doublecheck) \
+ $(use_with bzip2 bzlib) \
+ $(use_with gd) \
+ $(use_with glob) \
+ $(use_with ldap) \
+ $(use_with lzma liblzma) \
+ $(use_with pcre) \
+ $(use_with zlib) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}
+
+src_install() {
+ default
+
+ dodoc documentation/*
+}