summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-03 08:16:28 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-03 09:31:19 +0200
commitd6c9ce3966fb7eb89372953f374fb9a7c45b7975 (patch)
treecf42e390a34eb49aa0c42cb74b5a394a1a5f8282 /net-analyzer/scanssh/scanssh-2.1.2.ebuild
parentnet-analyzer/sflowtool: Version 5.05 (diff)
downloadgentoo-d6c9ce3966fb7eb89372953f374fb9a7c45b7975.tar.gz
gentoo-d6c9ce3966fb7eb89372953f374fb9a7c45b7975.tar.bz2
gentoo-d6c9ce3966fb7eb89372953f374fb9a7c45b7975.zip
net-analyzer/scanssh: Version 2.1.2
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/scanssh/scanssh-2.1.2.ebuild')
-rw-r--r--net-analyzer/scanssh/scanssh-2.1.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/scanssh/scanssh-2.1.2.ebuild b/net-analyzer/scanssh/scanssh-2.1.2.ebuild
new file mode 100644
index 000000000000..2e596b229bd5
--- /dev/null
+++ b/net-analyzer/scanssh/scanssh-2.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="network scanner that gathers info on SSH protocols and versions"
+HOMEPAGE="https://github.com/ofalk/scanssh/"
+SRC_URI="https://github.com/ofalk/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-libs/libdnet
+ dev-libs/libevent:=
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-warnings.diff
+ "${FILESDIR}"/${PN}-2.0-libdir.diff
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ DNETINC='' \
+ DNETLIB=-ldnet \
+ EVENTINC='' \
+ EVENTLIB=-levent \
+ PCAPINC='' \
+ PCAPLIB=-lpcap
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin scanssh
+ doman scanssh.1
+}