summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2018-06-03 22:20:09 +0100
committerMike Auty <ikelos@gentoo.org>2018-06-03 22:20:33 +0100
commit21ad4ca91961c605d7caa203f9530fb30ccf682e (patch)
tree36e71c852f6e392db1a83d58b195e39fcadb17a8 /net-analyzer/scapy/scapy-2.4.0.ebuild
parentapp-doc/doxygen: fix warning about unused variable if USE=-doc (diff)
downloadgentoo-21ad4ca91961c605d7caa203f9530fb30ccf682e.tar.gz
gentoo-21ad4ca91961c605d7caa203f9530fb30ccf682e.tar.bz2
gentoo-21ad4ca91961c605d7caa203f9530fb30ccf682e.zip
net-analyzer/scapy: Bump to 2.4.0, remove old versions.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/scapy/scapy-2.4.0.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.4.0.ebuild b/net-analyzer/scapy/scapy-2.4.0.ebuild
new file mode 100644
index 000000000000..87c9eb983d6f
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}