summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-07 06:59:38 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-07 07:01:11 +0200
commitc937ed6d755e0989c8c42f0f5fda33a756821173 (patch)
tree4396e211c71d6fb74815267beb4fef031201eb05 /net-analyzer/scapy/scapy-2.4.3.ebuild
parentsys-apps/firejail: remove old (diff)
downloadgentoo-c937ed6d755e0989c8c42f0f5fda33a756821173.tar.gz
gentoo-c937ed6d755e0989c8c42f0f5fda33a756821173.tar.bz2
gentoo-c937ed6d755e0989c8c42f0f5fda33a756821173.zip
net-analyzer/scapy: Version 2.4.3
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/scapy/scapy-2.4.3.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.4.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.4.3.ebuild b/net-analyzer/scapy/scapy-2.4.3.ebuild
new file mode 100644
index 000000000000..ccaf35b48e6c
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}