summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-10 13:50:02 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-10 13:54:24 +0200
commit3ea02c91dce90ad12716507d32633bcb923cf774 (patch)
tree77eb4e883f559ea0f00dbd84b371918d56842626 /net-analyzer/sngrep/sngrep-1.4.6-r3.ebuild
parentnet-analyzer/sngrep: Fix segmentation fault in ncurses (diff)
downloadgentoo-3ea02c91dce90ad12716507d32633bcb923cf774.tar.gz
gentoo-3ea02c91dce90ad12716507d32633bcb923cf774.tar.bz2
gentoo-3ea02c91dce90ad12716507d32633bcb923cf774.zip
net-analyzer/sngrep: Backport tinfo patch
- In case 1.4.7 has bugs that 1.4.6 does not, apply the fixed tinfo patch there as well. - The tinfo patch fixes the test suite problems as well, so drop RESTRICT=test again. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Bug: https://bugs.gentoo.org/709852 Bug: https://bugs.gentoo.org/727790 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/sngrep/sngrep-1.4.6-r3.ebuild')
-rw-r--r--net-analyzer/sngrep/sngrep-1.4.6-r3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/sngrep-1.4.6-r3.ebuild b/net-analyzer/sngrep/sngrep-1.4.6-r3.ebuild
new file mode 100644
index 000000000000..b9f731a5e648
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.4.6-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="https://github.com/irontec/sngrep/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eep gnutls ipv6 openssl pcre unicode"
+REQUIRED_USE="
+ gnutls? ( !openssl )
+"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=[unicode?]
+ openssl? ( dev-libs/openssl:0= )
+ gnutls? ( net-libs/gnutls )
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.6-stdin.patch
+ "${FILESDIR}"/${PN}-1.4.7-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable eep) \
+ $(use_enable ipv6) \
+ $(use_enable unicode) \
+ $(use_with gnutls) \
+ $(use_with openssl) \
+ $(use_with pcre)
+}