summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/snortsam/snortsam-2.50-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/snortsam/snortsam-2.50-r1.ebuild')
-rw-r--r--net-analyzer/snortsam/snortsam-2.50-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.50-r1.ebuild b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
new file mode 100644
index 000000000000..b9a5c9050434
--- /dev/null
+++ b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
+HOMEPAGE="http://www.snortsam.net/"
+SRC_URI="http://www.snortsam.net/files/snortsam/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-2.50-ciscoacl.diff.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # bug 155955, ciscoacl segfaults with gcc-4.1.1
+ epatch "${DISTDIR}"/${PN}-2.50-ciscoacl.diff.bz2
+ sed -i -e "s:sbin/functions.sh:etc/init.d/functions.sh:" \
+ -e "s: -O2 : ${CFLAGS} :" \
+ -e "s:gcc :$(tc-getCC) :" \
+ -e "s:\( -o ../snortsam\): ${LDFLAGS}\1:" makesnortsam.sh || die "sed failed"
+ ecvs_clean
+}
+
+src_compile() {
+ sh makesnortsam.sh || die "makesnortsam.sh failed"
+}
+
+src_install() {
+ dobin snortsam || die "dobin failed"
+ find "${S}" -depth -type f -name "*.asc" -exec rm -f {} \;
+ dodoc docs/* conf/*
+}
+
+pkg_postinst() {
+ elog
+ elog "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
+ elog "Read the INSTALL file to configure snort for snortsam, and configure"
+ elog "snortsam for your particular firewall."
+ elog
+}