summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-23 23:29:10 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-23 23:32:43 -0600
commit8be0944b21e45bbf9f15c51c33fdca5fab856765 (patch)
tree14a877314751c29402e362cf2f657a86e4bae317 /net-analyzer/speedtest-cli/speedtest-cli-2.1.2.ebuild
parentacct-user.eclass: Fix typo in eislocked() (diff)
downloadgentoo-8be0944b21e45bbf9f15c51c33fdca5fab856765.tar.gz
gentoo-8be0944b21e45bbf9f15c51c33fdca5fab856765.tar.bz2
gentoo-8be0944b21e45bbf9f15c51c33fdca5fab856765.zip
net-analyzer/speedtest-cli: version bump to 2.1.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-analyzer/speedtest-cli/speedtest-cli-2.1.2.ebuild')
-rw-r--r--net-analyzer/speedtest-cli/speedtest-cli-2.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/speedtest-cli/speedtest-cli-2.1.2.ebuild b/net-analyzer/speedtest-cli/speedtest-cli-2.1.2.ebuild
new file mode 100644
index 000000000000..8c5b2bfd8f88
--- /dev/null
+++ b/net-analyzer/speedtest-cli/speedtest-cli-2.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command line interface for testing internet bandwidth using speedtest.net"
+HOMEPAGE="https://github.com/sivel/speedtest-cli"
+SRC_URI="https://github.com/sivel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( CONTRIBUTING.md README.rst )
+
+python_install_all() {
+ doman ${PN}.1
+ distutils-r1_python_install_all
+}