summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/squidsites
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/squidsites')
-rw-r--r--net-analyzer/squidsites/Manifest1
-rw-r--r--net-analyzer/squidsites/files/squidsites-1.01-format-security.patch11
-rw-r--r--net-analyzer/squidsites/metadata.xml5
-rw-r--r--net-analyzer/squidsites/squidsites-1.01-r2.ebuild34
4 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/squidsites/Manifest b/net-analyzer/squidsites/Manifest
new file mode 100644
index 000000000000..d0111c0c82df
--- /dev/null
+++ b/net-analyzer/squidsites/Manifest
@@ -0,0 +1 @@
+DIST squidsites-1.01.tar.gz 23646 SHA256 5bf946a4ff3d4a695b695c28b7455071f08f1210f1bfee1bd340ee6211de75e0 SHA512 ecd6caf4ffbb531de1de85b2d8548e4256603909b1d1bc8c368516b644298803bc0cf3036a370ad679a763b94494bd755043df8a806dcca16990024c515cfed9 WHIRLPOOL b8bb650df49bed0d5037b006537bce14c2a6ee580a712af0745646ea9f32759a26a5351b9aef7404ec4ff7201d09e39d155d2e8c03582f826f39f6e48e427b8e
diff --git a/net-analyzer/squidsites/files/squidsites-1.01-format-security.patch b/net-analyzer/squidsites/files/squidsites-1.01-format-security.patch
new file mode 100644
index 000000000000..3dd72203c309
--- /dev/null
+++ b/net-analyzer/squidsites/files/squidsites-1.01-format-security.patch
@@ -0,0 +1,11 @@
+--- a/src/squidsites.c
++++ b/src/squidsites.c
+@@ -286,7 +286,7 @@
+ static
+ void print_help()
+ {
+- fprintf( stderr, help_message );
++ fprintf( stderr, "%s\n", help_message );
+ } /* print_help */
+
+
diff --git a/net-analyzer/squidsites/metadata.xml b/net-analyzer/squidsites/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/squidsites/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/squidsites/squidsites-1.01-r2.ebuild b/net-analyzer/squidsites/squidsites-1.01-r2.ebuild
new file mode 100644
index 000000000000..cc7141dd9466
--- /dev/null
+++ b/net-analyzer/squidsites/squidsites-1.01-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A tool that parses Squid access log file and generates a report of the most visited sites"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.stefanopassiglia.com/misc.htm"
+SRC_URI="http://www.stefanopassiglia.com/downloads/${P}.tar.gz"
+SLOT="1"
+KEYWORDS="amd64 ppc x86"
+
+S="${WORKDIR}/src"
+
+src_prepare() {
+ # Respect CFLAGS
+ sed -i Makefile \
+ -e '/^CCFLAGS=/s|-g| $(CFLAGS) $(LDFLAGS)|' \
+ || die
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ cd "${WORKDIR}" || die
+ dobin src/squidsites
+ dodoc Authors Bugs ChangeLog GNU-Manifesto.html README
+}