summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-30 10:12:48 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-30 10:50:55 +0200
commitb6626e5992a27bf66375e4a1b557dcc6c195bfe2 (patch)
tree52fcb4707e32d0da387a7afa9c98acf04f7031be /net-analyzer/ssh-audit/ssh-audit-2.9.0.ebuild
parentmedia-gfx/jpegoptim: misc ebuild updates (diff)
downloadgentoo-b6626e5992a27bf66375e4a1b557dcc6c195bfe2.tar.gz
gentoo-b6626e5992a27bf66375e4a1b557dcc6c195bfe2.tar.bz2
gentoo-b6626e5992a27bf66375e4a1b557dcc6c195bfe2.zip
net-analyzer/ssh-audit: add 2.9.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-analyzer/ssh-audit/ssh-audit-2.9.0.ebuild')
-rw-r--r--net-analyzer/ssh-audit/ssh-audit-2.9.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ssh-audit/ssh-audit-2.9.0.ebuild b/net-analyzer/ssh-audit/ssh-audit-2.9.0.ebuild
new file mode 100644
index 000000000000..9f83ff5f895c
--- /dev/null
+++ b/net-analyzer/ssh-audit/ssh-audit-2.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=(python3_{9,10,11})
+
+inherit distutils-r1
+
+DESCRIPTION="SSH server auditing (banner, key exchange, encryption, mac, compression, etc)"
+HOMEPAGE="https://github.com/jtesta/ssh-audit"
+SRC_URI="https://github.com/jtesta/ssh-audit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+# Tests require prospector which is not packaged
+RESTRICT="test"
+
+src_install() {
+ distutils-r1_src_install
+
+ doman ssh-audit.1
+}