summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-10-26 07:14:53 +0100
committerHans de Graaff <graaff@gentoo.org>2020-10-26 07:46:47 +0100
commitb1e25d80827aa7c6e405b34db76228d0a810df21 (patch)
tree410d451875de7e1d041a92ac4367890f3be29ded /net-analyzer/sslscan/sslscan-2.0.5.ebuild
parentnet-analyzer/sslscan: cleanup (diff)
downloadgentoo-b1e25d80827aa7c6e405b34db76228d0a810df21.tar.gz
gentoo-b1e25d80827aa7c6e405b34db76228d0a810df21.tar.bz2
gentoo-b1e25d80827aa7c6e405b34db76228d0a810df21.zip
net-analyzer/sslscan: add 2.0.5
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-analyzer/sslscan/sslscan-2.0.5.ebuild')
-rw-r--r--net-analyzer/sslscan/sslscan-2.0.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/sslscan/sslscan-2.0.5.ebuild b/net-analyzer/sslscan/sslscan-2.0.5.ebuild
new file mode 100644
index 000000000000..8deaf7cd4f79
--- /dev/null
+++ b/net-analyzer/sslscan/sslscan-2.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# sslscan builds against a static openssl library to allow weak ciphers
+# to be enabled so that they can be tested.
+OPENSSL_RELEASE_TAG="OpenSSL_1_1_1h"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Fast SSL configuration scanner"
+HOMEPAGE="https://github.com/rbsec/sslscan"
+SRC_URI="https://github.com/rbsec/sslscan/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/openssl/openssl/archive/${OPENSSL_RELEASE_TAG}.tar.gz -> ${PN}-${OPENSSL_RELEASE_TAG}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires a docker environment
+RESTRICT="test"
+
+# S="${WORKDIR}/${P}-${MY_FORK}"
+
+src_prepare() {
+ ln -s ../openssl-${OPENSSL_RELEASE_TAG} openssl || die
+ touch .openssl_is_fresh || die
+ sed -i -e '/openssl\/.git/,/fi/d' \
+ -e '/openssl test/d' Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake static
+}
+
+src_install() {
+ DESTDIR="${D}" emake install
+
+ dodoc Changelog README.md
+}