summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/synscan/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/synscan/files')
-rw-r--r--net-analyzer/synscan/files/synscan-5.01-build.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-analyzer/synscan/files/synscan-5.01-build.patch b/net-analyzer/synscan/files/synscan-5.01-build.patch
new file mode 100644
index 000000000000..79cf6943e185
--- /dev/null
+++ b/net-analyzer/synscan/files/synscan-5.01-build.patch
@@ -0,0 +1,79 @@
+diff -ur synscan-5.01.orig/configure.in synscan-5.01/configure.in
+--- synscan-5.01.orig/configure.in 2009-03-31 23:22:46.000000000 +0300
++++ synscan-5.01/configure.in 2010-06-14 00:31:06.000000000 +0300
+@@ -49,7 +49,7 @@
+ owd=`pwd`
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ CFLAGS="$CFLAGS -I$withval -I$withval/bpf"
+- LDFLAGS="$LDFLAGS -L$withval -lpcap"
++ LIBS="$LIBS -L$withval -lpcap"
+ else
+ AC_ERROR(pcap.h or libpcap.a not found in $withval)
+ fi
+@@ -57,12 +57,12 @@
+ esac ],
+ [ if test -f ${prefix}/include/pcap.h; then
+ CFLAGS="$CFLAGS -I${prefix}/include"
+- LDFLAGS="$LDFLAGS -L${prefix}/lib -lpcap"
++ LIBS="$LIBS -L${prefix}/lib -lpcap"
+ elif test -f /usr/include/pcap/pcap.h; then
+ CFLAGS="$CFLAGS -I/usr/include/pcap"
+- LDFLAGS="$LDFLAGS -lpcap"
++ LIBS="$LIBS -lpcap"
+ elif test -f /usr/include/pcap.h; then
+- LDFLAGS="$LDFLAGS -lpcap"
++ LIBS="$LIBS -lpcap"
+ else
+ AC_MSG_RESULT(no)
+ AC_ERROR(libpcap not found)
+@@ -73,12 +73,15 @@
+ ##
+ ## Check of getoptlong
+ ##
+-AC_CHECK_FUNCS([getopt_long],,
+- AC_CHECK_LIB([gnugetopt], getopt_long,
+- [ LDFLAGS="$LDFLAGS -lgnugetopt";
+- AC_DEFINE([HAVE_GETOPT_LONG])]
+- )
+-)
++ac_cv_have_getopt_long="no"
++AC_CHECK_FUNCS([getopt_long],
++ [ac_cv_have_getopt_long="yes"],
++ [AC_CHECK_LIB([gnugetopt], [getopt_long],
++ [ac_cv_have_getopt_long="yes"
++ LIBS="${LIBS} -lgnugetopt"])])
++if test "$ac_cv_have_getopt_long" != "no"; then
++ AC_DEFINE([HAVE_GETOPT_LONG])
++fi
+
+ ##
+ ## Output files
+diff -ur synscan-5.01.orig/Makefile.in synscan-5.01/Makefile.in
+--- synscan-5.01.orig/Makefile.in 2009-03-31 23:22:28.000000000 +0300
++++ synscan-5.01/Makefile.in 2010-06-14 00:32:19.000000000 +0300
+@@ -5,7 +5,7 @@
+
+ CC = @CC@
+ CFLAGS=@CFLAGS@ @DEFS@ -Wall
+-LDFLAGS = @LDFLAGS@
++LIBS = @LIBS@
+
+ OBJS_MINIMAL = \
+ common.o net.o obuf.o
+@@ -56,13 +56,13 @@
+ solaris-sparc-gcc:
+ $(MAKE) $(PROJ) \
+ CFLAGS="$(CFLAGS) -DBSD_COMP -DSOLARIS" \
+- LDFLAGS="$(LDFLAGS) -lsocket -lresolv -lnsl"
++ LIBS="$(LIBS) -lsocket -lresolv -lnsl"
+
+ synscan: synscan.c synscan.h ${OBJS}
+- ${CC} ${CFLAGS} $< ${OBJS} ${LDFLAGS} -o synscan
++ ${CC} ${LDFLAGS} ${CFLAGS} $< ${OBJS} ${LIBS} -o synscan
+
+ sslog: sslog.c ${OBJS}
+- ${CC} ${CFLAGS} $< ${OBJS} ${LDFLAGS} -o sslog
++ ${CC} ${LDFLAGS} ${CFLAGS} $< ${OBJS} ${LIBS} -o sslog
+
+ install:
+ mkdir -p -m 755 ${bindir}