summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-14 10:17:49 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-14 10:18:34 +0100
commitd519a73f43b47b831493aa3a17326d092bba9a03 (patch)
tree1592846304c3b9fc38cfa455d7a99fefc2f437b7 /net-analyzer/tcpdump
parentdev-vcs/git: Removed old (diff)
downloadgentoo-d519a73f43b47b831493aa3a17326d092bba9a03.tar.gz
gentoo-d519a73f43b47b831493aa3a17326d092bba9a03.tar.bz2
gentoo-d519a73f43b47b831493aa3a17326d092bba9a03.zip
net-analyzer/tcpdump: Drop test dependencies providing uudecode
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://bugs.gentoo.org/705398 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpdump')
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild91
-rw-r--r--net-analyzer/tcpdump/tcpdump-9999.ebuild1
2 files changed, 91 insertions, 1 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild b/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild
new file mode 100644
index 000000000000..2fc6154ef964
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="
+ https://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/tcpdump
+"
+SRC_URI="
+ https://www.tcpdump.org/release/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+drop-root libressl smi ssl samba suid test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ drop-root? ( sys-libs/libcap-ng )
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6m:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ drop-root? ( virtual/pkgconfig )
+ test? (
+ >=net-libs/libpcap-1.9.1
+ dev-lang/perl
+ )
+"
+
+pkg_setup() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+src_configure() {
+ if use drop-root; then
+ append-cppflags -DHAVE_CAP_NG_H
+ export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
+ fi
+
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${ESYSROOT}/usr") \
+ $(usex drop-root "--with-user=tcpdump" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_preinst() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}
diff --git a/net-analyzer/tcpdump/tcpdump-9999.ebuild b/net-analyzer/tcpdump/tcpdump-9999.ebuild
index a4285888f60c..53e77a2204b0 100644
--- a/net-analyzer/tcpdump/tcpdump-9999.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-9999.ebuild
@@ -38,7 +38,6 @@ DEPEND="
test? (
>=net-libs/libpcap-1.9.1
dev-lang/perl
- || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
)
"
PATCHES=(