summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-09-24 21:20:11 +0200
committerJeroen Roovers <jer@gentoo.org>2017-09-24 21:20:53 +0200
commit74f69824dfdf8dce95c971c0bfdb827e33bf3245 (patch)
tree89995bf927f2278d48abfd8c959776c9a2b8a053 /net-analyzer/tcpflow/tcpflow-1.5.0_alpha.ebuild
parentapp-forensics/dfxml: Do not install autotools helper. (diff)
downloadgentoo-74f69824dfdf8dce95c971c0bfdb827e33bf3245.tar.gz
gentoo-74f69824dfdf8dce95c971c0bfdb827e33bf3245.tar.bz2
gentoo-74f69824dfdf8dce95c971c0bfdb827e33bf3245.zip
net-analyzer/tcpflow: Version bump.
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/tcpflow/tcpflow-1.5.0_alpha.ebuild')
-rw-r--r--net-analyzer/tcpflow/tcpflow-1.5.0_alpha.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/tcpflow/tcpflow-1.5.0_alpha.ebuild b/net-analyzer/tcpflow/tcpflow-1.5.0_alpha.ebuild
new file mode 100644
index 000000000000..b5ae445887a7
--- /dev/null
+++ b/net-analyzer/tcpflow/tcpflow-1.5.0_alpha.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="A tool for monitoring, capturing and storing TCP connections flows"
+HOMEPAGE="https://github.com/simsong/tcpflow https://packages.qa.debian.org/t/tcpflow.html"
+SRC_URI="
+ https://github.com/simsong/${PN}/archive/${P/_/}.tar.gz
+ https://api.github.com/repos/simsong/dfxml/tarball/7d11eaa7da8d31f588ce8aecb4b4f5e7e8169ba6 -> dfxml-20170921.tar.gz
+ https://api.github.com/repos/simsong/be13_api/tarball/c81521d768bb78499c069fcd7c47adc8eee0350c -> be13_api-20170924.tar.gz
+"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+SLOT="0"
+IUSE="cairo test"
+
+RDEPEND="
+ app-forensics/afflib
+ dev-libs/boost:=
+ dev-libs/openssl:=
+ net-libs/http-parser:=
+ net-libs/libpcap
+ sys-libs/libcap-ng
+ sys-libs/zlib:=
+ cairo? (
+ x11-libs/cairo
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( sys-apps/coreutils )
+"
+S=${WORKDIR}/${PN}-${P/_/}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0_alpha-gentoo.patch
+ "${FILESDIR}"/${PN}-1.5.0_alpha-libcapng.patch
+)
+
+src_prepare() {
+ mv "${WORKDIR}"/simsong-dfxml-7d11eaa/* src/dfxml/ || die
+ mv "${WORKDIR}"/simsong-be13_api-c81521d/* src/be13_api/ || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -fpermissive
+ econf $(usex cairo --enable-cairo=true --enable-cairo=false)
+}