summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-15 09:27:12 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-15 09:30:52 +0200
commita7f07d5ca45c74621c4dbc51d030cf50ecb50864 (patch)
tree520dadda0216661461a558636bea9698cf4647fd /net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild
parentapp-portage/nattka: Bump to 0.2.9 (diff)
downloadgentoo-a7f07d5ca45c74621c4dbc51d030cf50ecb50864.tar.gz
gentoo-a7f07d5ca45c74621c4dbc51d030cf50ecb50864.tar.bz2
gentoo-a7f07d5ca45c74621c4dbc51d030cf50ecb50864.zip
net-analyzer/tcpreplay: Version 4.3.3
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Bug: https://bugs.gentoo.org/show_bug.cgi?id=721662 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild')
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild
new file mode 100644
index 000000000000..015df52f86f9
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+LICENSE="BSD GPL-3"
+SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+DEPEND="
+ >=sys-devel/autogen-5.18.4[libopts]
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ tcpdump? ( net-analyzer/tcpdump )
+ pcapnav? ( net-libs/libpcapnav )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ docs/{CHANGELOG,CREDIT,HACKING,TODO}
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug 252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]]; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}