summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch')
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
new file mode 100644
index 000000000000..d7b42147ae1e
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
@@ -0,0 +1,24 @@
+--- thc-ipv6-2.1/Makefile
++++ thc-ipv6-2.1/Makefile
+@@ -4,7 +4,7 @@
+
+ CC=gcc
+ #CFLAGS=-g
+-CFLAGS=-O2
++CFLAGS?=-O2
+ CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
+ LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
+ PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6
+@@ -17,10 +17,10 @@
+ all: $(LIBS) $(PROGRAMS) dnssecwalk dnsdict6 thcping6
+
+ dnssecwalk: dnssecwalk.c
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ dnsdict6: dnsdict6.c
+- $(CC) $(CFLAGS) -o $@ $^ -lpthread -lresolv
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lpthread -lresolv
+
+ thcping6: thcping6.c $(LIBS)
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lrt