summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-12-18 14:21:17 +0100
committerMichael Weber <xmw@gentoo.org>2017-12-18 14:22:17 +0100
commit40977ebaba49d5200c18e942b30ac13939c0cc60 (patch)
treec459e5cc5b2a20b9081e1923b2eeaf58107eb441 /net-analyzer/thc-ipv6/thc-ipv6-3.2.ebuild
parentsci-physics/root: drop unused patches (diff)
downloadgentoo-40977ebaba49d5200c18e942b30ac13939c0cc60.tar.gz
gentoo-40977ebaba49d5200c18e942b30ac13939c0cc60.tar.bz2
gentoo-40977ebaba49d5200c18e942b30ac13939c0cc60.zip
net-analyzer/thc-ipv6: Version bump and add stdint.h include.
Closes: https://bugs.gentoo.org/639826 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-3.2.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-3.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-3.2.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-3.2.ebuild
new file mode 100644
index 000000000000..a0934cf80b9a
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == *9999 ]] && SCM="git-r3"
+EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
+EGIT_BRANCH=master
+
+inherit eutils toolchain-funcs ${SCM}
+
+DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="https://www.thc.org/thc-ipv6/"
+LICENSE="AGPL-3 openssl"
+SLOT="0"
+IUSE="ssl"
+
+if [[ ${PV} != *9999 ]]; then
+ SRC_URI="https://github.com/vanhauser-thc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="net-libs/libpcap
+ net-libs/libnetfilter_queue
+ ssl? ( dev-libs/openssl:* )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.2-stdint.patch" )
+
+src_unpack() {
+ if [[ ${PV} != *9999 ]]; then
+ default_src_unpack
+ else
+ git-r3_src_unpack
+ fi
+}
+
+src_prepare() {
+ sed -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
+ -i Makefile || die
+ if ! use ssl ; then
+ sed -e '/^HAVE_SSL/s:^:#:' \
+ -i Makefile
+ fi
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
+ dodoc CHANGES HOWTO-INJECT README
+}