summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-05 04:08:51 +0100
committerSam James <sam@gentoo.org>2021-09-05 06:24:45 +0100
commit9d9a6d7aeed1a2a6043aed24a0a6fddbdd7d488c (patch)
tree4f47ca42d5826bc6692f12117c72354ac5fce316 /net-analyzer/vnstat
parentgames-engines/box2d: conditionally build tests (diff)
downloadgentoo-9d9a6d7aeed1a2a6043aed24a0a6fddbdd7d488c.tar.gz
gentoo-9d9a6d7aeed1a2a6043aed24a0a6fddbdd7d488c.tar.bz2
gentoo-9d9a6d7aeed1a2a6043aed24a0a6fddbdd7d488c.zip
net-analyzer/vnstat: add 2.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/vnstat')
-rw-r--r--net-analyzer/vnstat/Manifest2
-rw-r--r--net-analyzer/vnstat/vnstat-2.8.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/net-analyzer/vnstat/Manifest b/net-analyzer/vnstat/Manifest
index 303e92c6e949..ddd03e8d9275 100644
--- a/net-analyzer/vnstat/Manifest
+++ b/net-analyzer/vnstat/Manifest
@@ -4,3 +4,5 @@ DIST vnstat-2.6.tar.gz 275751 BLAKE2B 7351b265d66e42d1e5450dae6f5eaa973a9cdc171b
DIST vnstat-2.6.tar.gz.asc 833 BLAKE2B 5e79d1b622dd4d37603a209b78018a3e88f2c404c700e1f439e4b98e2c2dd5bdf26e8ecd3b1b1242e14a725d7839c5a8b3b5448dc27e1f917cbeaf6012546656 SHA512 c643152bec14b70317465f8adc2256b41b8686e106b35ce492ad5030c2d5b32162441ac5fb2f309071da855efdf444076288cf075d8073bad0c0907067366e7f
DIST vnstat-2.7.tar.gz 287304 BLAKE2B f7b50cccfe4b62bce45751e6029650dc6d8ac7b7925cc4177fb1772c6d842b5201f6834d5e6374016b4c42374660b1c127d5b021adffe873de0a4c484171b6b3 SHA512 3d1674ddb5269d29d4d758551dc3e58fb1858a7dd790914c7d74047443b25d242c91f8ab20bdede9c1b061d6b682d73f3d6c1a8aa656a9676bc33c0ed9b1b2d4
DIST vnstat-2.7.tar.gz.asc 833 BLAKE2B ae9bb28ccd9f10e7ac0c32e9895140cdd9d8498ef18d9b716ffbed3c6693ff08e5ddb08c377ec009df881f7fc1666f09da48cee75857566bdd4f1a2be30a97b9 SHA512 dd1ae2d94400aee9622c28385a103680ca87abfb66b5c92e8ce7240b97f28e81ac1a9cfc97fff7cd6d3934bfa639f46c835acbf855c7a4a29309946d7cbd80d4
+DIST vnstat-2.8.tar.gz 290644 BLAKE2B 21ff801ce6abb135c26eb937eadb447bea9fd3dcb2af123051edb9861e088d8fc217f84ef2d924fe8b480388cfc761d0259f8abb2312ae49c2840643787d49bd SHA512 207aa1699df298ce3008153701782634a96a239599d17a5b2f1fbb298a9cf8edb35298e2de1f4f93415ddf34e0bdb831f95984b47fdd7f89ecc6aeb4821a0afd
+DIST vnstat-2.8.tar.gz.asc 833 BLAKE2B 097d37e1916924901f10d09bba882357c0eb81cf71fca921dbc642735ec8c0bde97f7ab63cd3953718c21687e6f39099cf2446210f41f3698b39b74116c4c025 SHA512 d5448d68da92d434cc6a34e007002c81ed8d97e533bf99364d3f65b4125bd6f21fe2f6f6efb97775ecc4ba4afd09e12add71ae2299a2d990a7a9d0a591c32811
diff --git a/net-analyzer/vnstat/vnstat-2.8.ebuild b/net-analyzer/vnstat/vnstat-2.8.ebuild
new file mode 100644
index 000000000000..02ba926a4b8b
--- /dev/null
+++ b/net-analyzer/vnstat/vnstat-2.8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
+HOMEPAGE="https://humdi.net/vnstat/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vergoh/vnstat"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/teemutoivola.asc
+ inherit verify-sig
+
+ SRC_URI="https://humdi.net/vnstat/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://humdi.net/vnstat/${P}.tar.gz.asc )"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+ BDEPEND="verify-sig? ( app-crypt/openpgp-keys-teemutoivola )"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gd selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/vnstat
+ acct-user/vnstat
+ dev-db/sqlite
+ gd? ( media-libs/gd[png] )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/check )
+"
+RDEPEND+=" selinux? ( sec-policy/selinux-vnstatd )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-conf.patch
+ "${FILESDIR}"/${PN}-2.2-drop-root.patch
+ "${FILESDIR}"/${PN}-2.2-run.patch
+)
+
+src_compile() {
+ emake \
+ ${PN} \
+ ${PN}d \
+ $(usex gd ${PN}i '')
+}
+
+src_install() {
+ use gd && dobin vnstati
+ dobin vnstat vnstatd
+
+ exeinto /usr/share/${PN}
+ newexe "${FILESDIR}"/vnstat.cron-r1 vnstat.cron
+
+ insinto /etc
+ doins cfg/vnstat.conf
+ fowners root:vnstat /etc/vnstat.conf
+
+ keepdir /var/lib/vnstat
+ fowners vnstat:vnstat /var/lib/vnstat
+
+ newconfd "${FILESDIR}"/vnstatd.confd-r1 vnstatd
+ newinitd "${FILESDIR}"/vnstatd.initd-r2 vnstatd
+
+ systemd_newunit "${FILESDIR}"/vnstatd.systemd vnstatd.service
+ newtmpfiles "${FILESDIR}"/vnstatd.tmpfile vnstatd.conf
+
+ use gd && doman man/vnstati.1
+
+ doman man/vnstat.1 man/vnstatd.8
+
+ newdoc INSTALL README.setup
+ dodoc CHANGES README UPGRADE FAQ examples/vnstat.cgi
+}
+
+pkg_postinst() {
+ tmpfiles_process vnstatd.conf
+}