summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-02 00:45:52 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-02 00:47:14 +0100
commitf5e907016bf8e78acff65a5b1f4ca99c4ffa89b9 (patch)
tree3138bbf8c4eea0a14d4d41a2b570ea65deb01f4d /net-analyzer/wapiti/wapiti-3.1.6.ebuild
parentdev-python/tld: update EAPI 7 -> 8 and python versions (diff)
downloadgentoo-f5e907016bf8e78acff65a5b1f4ca99c4ffa89b9.tar.gz
gentoo-f5e907016bf8e78acff65a5b1f4ca99c4ffa89b9.tar.bz2
gentoo-f5e907016bf8e78acff65a5b1f4ca99c4ffa89b9.zip
net-analyzer/wapiti: add 3.1.6
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-analyzer/wapiti/wapiti-3.1.6.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-3.1.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/wapiti/wapiti-3.1.6.ebuild b/net-analyzer/wapiti/wapiti-3.1.6.ebuild
new file mode 100644
index 000000000000..3ab9a88d574c
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.1.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+)'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+IUSE="test"
+
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
+RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/tld[${PYTHON_USEDEP}]
+ dev-python/yaswfp[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+# Many tests require execution of local test php server
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' \
+ -e "/DOC_DIR =/s/wapiti/${PF}/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}