summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-04 00:48:41 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-04 00:49:14 +0200
commit5c8a871809894c0f740af2959afe69d8e1c2277d (patch)
tree80d6434eff78dca534d8e60f58c88e082cd4053b /net-analyzer/wapiti
parentnet-analyzer/wapiti: add 3.1.2 (diff)
downloadgentoo-5c8a871809894c0f740af2959afe69d8e1c2277d.tar.gz
gentoo-5c8a871809894c0f740af2959afe69d8e1c2277d.tar.bz2
gentoo-5c8a871809894c0f740af2959afe69d8e1c2277d.zip
net-analyzer/wapiti: sync live ebuild
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-analyzer/wapiti')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index 95c1263aa07a..e9d25d0eedfd 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='xml'
inherit distutils-r1 git-r3
@@ -15,25 +15,33 @@ EGIT_REPO_URI="https://git.code.sf.net/p/wapiti/git wapiti-git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="kerberos ntlm"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
>=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]
- kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
- ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+ dev-python/yaswfp[${PYTHON_USEDEP}]"
distutils_enable_tests --install pytest
-BDEPEND+=" test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
# Many tests require execution of local test php server
RESTRICT="test"
python_prepare_all() {
sed -e 's/"pytest-runner"//' \
- -e "/find_packages/s/()/(exclude=['tests*'])/" \
-e "/DOC_DIR =/s/wapiti/${PF}/" \
-i setup.py || die
distutils-r1_python_prepare_all