summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-03 14:11:25 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-03 14:12:12 +0200
commit1ed92cf1f83756341e962f39e9c6f85cda353ed8 (patch)
treeddba468a6c0f9d42d4c92ad3bf02f75fb7e5e93c /net-analyzer/wireshark
parentmedia-video/kino: Drop 1.3.4 (diff)
downloadgentoo-1ed92cf1f83756341e962f39e9c6f85cda353ed8.tar.gz
gentoo-1ed92cf1f83756341e962f39e9c6f85cda353ed8.tar.bz2
gentoo-1ed92cf1f83756341e962f39e9c6f85cda353ed8.zip
net-analyzer/wireshark: Update live ebuild.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch34
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch11
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild20
3 files changed, 51 insertions, 14 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
new file mode 100644
index 000000000000..8ceb3ba54882
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
@@ -0,0 +1,34 @@
+--- a/extcap/CMakeLists.txt
++++ b/extcap/CMakeLists.txt
+@@ -68,6 +68,8 @@
+ if(HAVE_LIBPCAP)
+ set(androiddump_LIBS
+ ui
++ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ )
+@@ -78,6 +80,7 @@
+ set(androiddump_LIBS
+ ui
+ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+@@ -89,7 +92,6 @@
+ )
+
+ add_executable(androiddump WIN32 ${androiddump_FILES})
+- # XXX Shouldn't we add wsutil to androiddump_LIBS instead?
+ set_extcap_executable_properties(androiddump)
+ target_link_libraries(androiddump ${androiddump_LIBS})
+ install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})
+@@ -212,4 +214,4 @@
+ ${androiddump_FILES}
+ ${sshdump_FILES}
+ ${ciscodump_FILES}
+-)
+\ No newline at end of file
++)
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch b/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch
new file mode 100644
index 000000000000..c0bfc3acd5a6
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch
@@ -0,0 +1,11 @@
+--- a/ui/CMakeLists.txt
++++ b/ui/CMakeLists.txt
+@@ -76,6 +76,8 @@
+
+ add_library(ui STATIC ${UI_SRC})
+
++set(ui_LIBS wiretap)
++
+ set_target_properties(ui PROPERTIES
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ FOLDER "UI"
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 039381a543b2..d1a9875cba39 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -13,8 +13,8 @@ SLOT="0/${PV}"
KEYWORDS=""
IUSE="
adns androiddump bcg729 +capinfos +caps +captype ciscodump +dftest doc
- +dumpcap +editcap gtk kerberos libxml2 lua lz4 maxminddb +mergecap +netlink
- nghttp2 +pcap portaudio +qt5 +randpkt +randpktdump +reordercap sbc selinux
+ +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink
+ nghttp2 +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux
+sharkd smi snappy spandsp sshdump ssl +text2pcap tfshark +tshark +udpdump
zlib
"
@@ -28,12 +28,6 @@ CDEPEND="
adns? ( >=net-dns/c-ares-1.5 )
bcg729? ( media-libs/bcg729 )
caps? ( sys-libs/libcap )
- gtk? (
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
- x11-libs/pango
- x11-misc/xdg-utils
- )
kerberos? ( virtual/krb5 )
sshdump? ( >=net-libs/libssh-0.6 )
ciscodump? ( >=net-libs/libssh-0.6 )
@@ -43,7 +37,6 @@ CDEPEND="
maxminddb? ( dev-libs/libmaxminddb )
nghttp2? ( net-libs/nghttp2 )
pcap? ( net-libs/libpcap )
- portaudio? ( media-libs/portaudio )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -81,14 +74,15 @@ DEPEND="
"
RDEPEND="
${CDEPEND}
- gtk? ( virtual/freedesktop-icon-theme )
qt5? ( virtual/freedesktop-icon-theme )
selinux? ( sec-policy/selinux-wireshark )
"
PATCHES=(
"${FILESDIR}"/${PN}-2.4-androiddump.patch
- "${FILESDIR}"/${PN}-99999999-qtsvg.patch
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
+ "${FILESDIR}"/${PN}-99999999-androiddump-wsutil.patch
+ "${FILESDIR}"/${PN}-99999999-qtsvg.patch
+ "${FILESDIR}"/${PN}-99999999-ui-needs-wiretap.patch
)
pkg_setup() {
@@ -141,7 +135,6 @@ src_configure() {
-DBUILD_tshark=$(usex tshark)
-DBUILD_udpdump=$(usex udpdump)
-DBUILD_wireshark=$(usex qt5)
- -DBUILD_wireshark_gtk=$(usex gtk)
-DDISABLE_WERROR=yes
-DENABLE_BCG729=$(usex bcg729)
-DENABLE_CAP=$(usex caps)
@@ -154,7 +147,6 @@ src_configure() {
-DENABLE_NETLINK=$(usex netlink)
-DENABLE_NGHTTP2=$(usex nghttp2)
-DENABLE_PCAP=$(usex pcap)
- -DENABLE_PORTAUDIO=$(usex portaudio)
-DENABLE_SBC=$(usex sbc)
-DENABLE_SMI=$(usex smi)
-DENABLE_SNAPPY=$(usex snappy)
@@ -204,7 +196,7 @@ src_install() {
insinto /usr/include/wiretap
doins wiretap/wtap.h
- if use gtk || use qt5; then
+ if use qt5; then
local s
for s in 16 32 48 64 128 256 512 1024; do
insinto /usr/share/icons/hicolor/${s}x${s}/apps