summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-14 15:23:33 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-14 15:27:31 +0200
commit008b9d6bae34bcd311ba4cce6ef50a1e2526e9d4 (patch)
tree0fd1c5f1aa174e3b10fb2abae6180932e43009a5 /net-analyzer
parentsys-auth/nss-pam-ldapd: cleanup (diff)
downloadgentoo-008b9d6bae34bcd311ba4cce6ef50a1e2526e9d4.tar.gz
gentoo-008b9d6bae34bcd311ba4cce6ef50a1e2526e9d4.tar.bz2
gentoo-008b9d6bae34bcd311ba4cce6ef50a1e2526e9d4.zip
net-analyzer/httping: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/Manifest1
-rw-r--r--net-analyzer/httping/httping-2.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-analyzer/httping/Manifest b/net-analyzer/httping/Manifest
index 2c43a9f0c70d..9086dd37eb7b 100644
--- a/net-analyzer/httping/Manifest
+++ b/net-analyzer/httping/Manifest
@@ -1 +1,2 @@
DIST httping-2.4.tgz 54170 SHA256 dab59f02b08bfbbc978c005bb16d2db6fe21e1fc841fde96af3d497ddfc82084 SHA512 11d9e9e3b222548c9754cc0e7bf947f1a55ccc9f1a2401681f95d21b7b7a56c07665955b558a56d07a5c98497ea3644758e4f85006c42fda2134556be8d9e804 WHIRLPOOL eb1318094eb22aa2186421f04c26c4e980a41ba901a3bf80ab50e036417d3cf241bdef26a397b6e6f337cf48fdf3e19627cde82ef6b0ed4c6e3525d1c13a0cf6
+DIST httping-2.5.tgz 71400 SHA256 3e895a0a6d7bd79de25a255a1376d4da88eb09c34efdd0476ab5a907e75bfaf8 SHA512 397ce2eac91c9aede0eb19823bfca4e7f98c263937f5954c8a48d5248a251d2030e31f18decb7f7f8b0118ec0e16ec0a84ea4c943ccde7056b80de162954c355 WHIRLPOOL e392fbbedd7a55ebc76aca562471e3a8b1cbbcacaf5773558ef12767425e9ed95b59835539cf1142b675a683ff11646526a90556e737cf410ab0c750f5d3a841
diff --git a/net-analyzer/httping/httping-2.5.ebuild b/net-analyzer/httping/httping-2.5.ebuild
new file mode 100644
index 000000000000..25937a3776d6
--- /dev/null
+++ b/net-analyzer/httping/httping-2.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug fftw libressl l10n_nl ncurses ssl tfo"
+
+RDEPEND="
+ fftw? ( sci-libs/fftw:3.0 )
+ ncurses? ( sys-libs/ncurses:0= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ ncurses? ( virtual/pkgconfig )
+"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.1-flags.patch
+)
+
+src_prepare() {
+ default
+
+ # doman does not get PN-LANG.CAT so we move things around and then point at
+ # it later
+ if use l10n_nl; then
+ mkdir nl || die
+ mv httping-nl.1 nl/httping.1 || die
+ fi
+}
+
+src_configure() {
+ # not an autotools script
+ echo > makefile.inc || die
+
+ use ncurses && LDFLAGS+=" $( $( tc-getPKG_CONFIG ) --libs ncurses )"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ FW=$(usex fftw) \
+ DEBUG=$(usex debug) \
+ NC=$(usex ncurses) \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+
+ use l10n_nl && doman -i18n=nl nl/httping.1
+}