summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-03 18:20:06 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-03 18:20:06 +0200
commit0aba05157b1220eee7942033b97ff75639e061eb (patch)
tree3600acdaee591ee6af7d2968cf87bc8811a7933b /net-analyzer
parentdev-python/sphinx-prompt: Keyword 1.3.0 arm, #746137 (diff)
downloadgentoo-0aba05157b1220eee7942033b97ff75639e061eb.tar.gz
gentoo-0aba05157b1220eee7942033b97ff75639e061eb.tar.bz2
gentoo-0aba05157b1220eee7942033b97ff75639e061eb.zip
net-analyzer/argus: Pass AR/RANLIB to emake
Closes: https://bugs.gentoo.org/724836 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/argus/argus-3.0.8.3-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/argus/argus-3.0.8.3-r1.ebuild b/net-analyzer/argus/argus-3.0.8.3-r1.ebuild
index bc999ce39081..cc378b5cf4b8 100644
--- a/net-analyzer/argus/argus-3.0.8.3-r1.ebuild
+++ b/net-analyzer/argus/argus-3.0.8.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="network Audit Record Generation and Utilization System"
HOMEPAGE="https://openargus.org/"
@@ -64,7 +64,10 @@ src_configure() {
}
src_compile() {
- emake CCOPT="${CFLAGS} ${LDFLAGS}"
+ emake \
+ CCOPT="${CFLAGS} ${LDFLAGS}" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)"
}
src_install() {