summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-20 01:09:11 -0400
committerSam James <sam@gentoo.org>2024-03-20 06:17:00 +0000
commit24a101998bd9f0e2d5565100971aa0a7cc0b97ec (patch)
tree6b343a5c995504d7a29cbc0273ab2ab202e3f6ca /net-analyzer
parentnet-analyzer/snort: update broken upstream urls (diff)
downloadgentoo-24a101998bd9f0e2d5565100971aa0a7cc0b97ec.tar.gz
gentoo-24a101998bd9f0e2d5565100971aa0a7cc0b97ec.tar.bz2
gentoo-24a101998bd9f0e2d5565100971aa0a7cc0b97ec.zip
net-analyzer/tcptrace: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/861260 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
index 6757aed273ce..5453f2914699 100644
--- a/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="A Tool for analyzing network packet dumps"
HOMEPAGE="http://www.tcptrace.org/"
@@ -38,6 +38,19 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861260
+ #
+ # Upstream site no longer exists.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_compile() {
emake CCOPT="${CFLAGS}"
}