summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-08-04 12:06:28 +0200
committerJeroen Roovers <jer@gentoo.org>2016-08-04 12:06:28 +0200
commit32642c702134d7d7074caa1a913a1a6a7971d385 (patch)
treee0244a6139864bcafb72ad54e43225ed1b2eee06 /net-analyzer
parentnet-libs/nodejs: Mark ~ppc64 too. (diff)
downloadgentoo-32642c702134d7d7074caa1a913a1a6a7971d385.tar.gz
gentoo-32642c702134d7d7074caa1a913a1a6a7971d385.tar.bz2
gentoo-32642c702134d7d7074caa1a913a1a6a7971d385.zip
net-analyzer/mtr: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/mtr/Manifest1
-rw-r--r--net-analyzer/mtr/mtr-0.87.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/mtr/Manifest b/net-analyzer/mtr/Manifest
index 0ae35c92dcd4..b57934af17d3 100644
--- a/net-analyzer/mtr/Manifest
+++ b/net-analyzer/mtr/Manifest
@@ -1,2 +1,3 @@
DIST gtk-2.0-for-mtr.m4.bz2 2508 SHA256 59152f9a4a1af5cf09f2aaa804c9071afe3eb6632162f1660d85c820db342eba SHA512 0f593b761d7a9399469f1f7bb3992133b391a2ce760ecfad96237561992802c192b810f4722763685d5f6e7a76bd2806abf08e1850bdce00e5cd3af4c810210f WHIRLPOOL 8bfa2cd70c2aba06473692cdf3e091a983aab69cdb5be3d0382b6b87c05bcc577ecb1afab26afc17ee16d07a1161fe84f17e3cc9ae0a150364f34667cfba5779
DIST mtr-0.86.tar.gz 185374 SHA256 c5d948920b641cc35f8b380fc356ddfe07cce6a9c6474afe242fc58113f28c06 SHA512 e649825ab77987e369e0cd353a502b31f4aafa54a934467db907cb171af45b11bd0a8725d567d923422f32b886ad272b42151514c71893f0ba947f8d18719583 WHIRLPOOL bcf736514a48d6db24d1abf5c8d8b6c792fa8726b646d88d2810bf5f1ed237439a49dd4365f88cee1a9ebe3956cd2f30020abcc7a0d0b368161e0f1053dab290
+DIST mtr-0.87.tar.gz 184645 SHA256 193947c61d23b154c8dc03677e90e8fd912f8f18567ab76ce619b7856c4af19f SHA512 172ba2f78a6ee4deb427ac2fb00dff16843215dbd23663fbe41fcc957ffe278b408a73a0c7e1c05788b235e2d03fb53f9971b8b82d4de2f95edcaa9f2cff3cf9 WHIRLPOOL 39fc9b60c1eccfdb1159a184f7089f13d1a8fbc35f16b7c23b746f3da709894f99571a57ef3431ca601112691c0e693b86a9941ed20bc236d2630f282e43d641
diff --git a/net-analyzer/mtr/mtr-0.87.ebuild b/net-analyzer/mtr/mtr-0.87.ebuild
new file mode 100644
index 000000000000..afac24180f50
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.87.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils fcaps flag-o-matic
+
+DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="gtk ipv6"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/autoconf
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
+FILECAPS=( cap_net_raw /usr/sbin/mtr )
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # In the source's configure script -lresolv is commented out. Apparently it
+ # is needed for 64bit macos still.
+ [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with gtk) \
+ --disable-gtktest
+}