summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 16:29:06 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:21:41 +0000
commit3b12e502441b138f103d574e7cfb193c45a81871 (patch)
treeb47e8cfbc914ddf963a3d1c6a9d5d909a62674da /net-analyzer
parentnet-analyzer/arpon: drop 2.7.2, 2.7.2-r1 (diff)
downloadgentoo-3b12e502441b138f103d574e7cfb193c45a81871.tar.gz
gentoo-3b12e502441b138f103d574e7cfb193c45a81871.tar.bz2
gentoo-3b12e502441b138f103d574e7cfb193c45a81871.zip
net-analyzer/arpon: minor ebuild tidying
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/arpon/arpon-3.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-analyzer/arpon/arpon-3.0.ebuild b/net-analyzer/arpon/arpon-3.0.ebuild
index f84ce3dfbc6d..c800c3568c29 100644
--- a/net-analyzer/arpon/arpon-3.0.ebuild
+++ b/net-analyzer/arpon/arpon-3.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit cmake
DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler"
@@ -10,6 +11,7 @@ MY_PN="ArpON"
MY_P="${MY_PN}-${PV}"
HOMEPAGE="http://arpon.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}-ng.tar.gz"
+S="${WORKDIR}"/${MY_P}-ng
LICENSE="BSD-2"
SLOT="0"
@@ -20,18 +22,18 @@ DEPEND="
net-libs/libnet:1.1
net-libs/libpcap
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+
PATCHES=(
"${FILESDIR}"/${PN}-3.0-CFLAGS.patch
"${FILESDIR}"/${PN}-3.0-gentoo.patch
)
+
DOCS=( AUTHOR CHANGELOG README THANKS )
-S="${WORKDIR}"/${MY_P}-ng
src_install() {
cmake_src_install
+
newinitd "${FILESDIR}"/${PN}.initd-3 ${PN}
newconfd "${FILESDIR}"/${PN}.confd-3 ${PN}