summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-05-27 23:06:55 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:41:52 +0200
commit3f98aec59be6928f3b01c157fb7b60656162e815 (patch)
tree2aae751f67492bf6fc8d87dbf9daea40f8bf48a6 /net-analyzer
parentdev-python/pushbullet-py: bump to 0.11.0, add py3.6 (diff)
downloadgentoo-3f98aec59be6928f3b01c157fb7b60656162e815.tar.gz
gentoo-3f98aec59be6928f3b01c157fb7b60656162e815.tar.bz2
gentoo-3f98aec59be6928f3b01c157fb7b60656162e815.zip
net-analyzer/sancp: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=594728 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4784
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sancp/files/sancp-1.6.1-gcc6.patch26
-rw-r--r--net-analyzer/sancp/sancp-1.6.1-r4.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/sancp/files/sancp-1.6.1-gcc6.patch b/net-analyzer/sancp/files/sancp-1.6.1-gcc6.patch
new file mode 100644
index 000000000000..e56d7114468e
--- /dev/null
+++ b/net-analyzer/sancp/files/sancp-1.6.1-gcc6.patch
@@ -0,0 +1,26 @@
+--- a/pcapFileHandle.h
++++ b/pcapFileHandle.h
+@@ -16,7 +16,12 @@
+
+ #define PCAP_HEADER_SIZE 24
+
+-const char pcap_header[] = { 0xd4,0xc3,0xb2,0xa1,0x02,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x4e,0x00,0x00,0x01,0x00,0x00,0x00 };
++const char pcap_header[] = {
++ (char) 0xd4,(char) 0xc3,(char) 0xb2,(char) 0xa1,(char) 0x02,(char) 0x00,
++ (char) 0x04,(char) 0x00,(char) 0x00,(char) 0x00,(char) 0x00,(char) 0x00,
++ (char) 0x00,(char) 0x00,(char) 0x00,(char) 0x00,(char) 0x20,(char) 0x4e,
++ (char) 0x00,(char) 0x00,(char) 0x01,(char) 0x00,(char) 0x00,(char) 0x00
++};
+
+ class pcapFileHandle : public fileHandle {
+
+--- a/sancp.h
++++ b/sancp.h
+@@ -223,7 +223,6 @@
+ #define R_URG 0x20
+ #define R_RES2 0x40
+ #define R_RES1 0x80
+-#define max(i,j) (((i)>(j)) ? (i) : (j))
+ #define SIZE_OF_CLASS_C 11
+
+ struct t_ports {
diff --git a/net-analyzer/sancp/sancp-1.6.1-r4.ebuild b/net-analyzer/sancp/sancp-1.6.1-r4.ebuild
index aa665e1ec71a..4f1bfd0b4e9f 100644
--- a/net-analyzer/sancp/sancp-1.6.1-r4.ebuild
+++ b/net-analyzer/sancp/sancp-1.6.1-r4.ebuild
@@ -37,6 +37,7 @@ src_prepare() {
epatch "${DISTDIR}"/${PN}-1.6.1.fix200601.c.patch
epatch "${DISTDIR}"/${PN}-1.6.1.fix200606.d.patch
epatch "${FILESDIR}"/${P}-compiler.patch
+ epatch "${FILESDIR}"/${P}-gcc6.patch
tc-export CXX CC
}