summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-23 14:12:31 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-23 14:13:27 +0200
commit48d8cf183b05ac894acd5ad38dcc6152b7f95adc (patch)
tree905c55f20d090882ccdc571f9c2e24e5c20d67be /net-analyzer
parentgames-board/gnugo: Fix building against GCC 10 (diff)
downloadgentoo-48d8cf183b05ac894acd5ad38dcc6152b7f95adc.tar.gz
gentoo-48d8cf183b05ac894acd5ad38dcc6152b7f95adc.tar.bz2
gentoo-48d8cf183b05ac894acd5ad38dcc6152b7f95adc.zip
net-analyzer/wireshark: Provide correct ctest argument
According to test/test.py we should use --skip-missing-programs=all. It does not work, of course, but it is a small step on the way. Package-Manager: Portage-2.3.101, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-3.2.4.ebuild2
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.2.4.ebuild b/net-analyzer/wireshark/wireshark-3.2.4.ebuild
index 4f4102a716e1..33ae5ea2b3f8 100644
--- a/net-analyzer/wireshark/wireshark-3.2.4.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.2.4.ebuild
@@ -181,7 +181,7 @@ src_configure() {
src_test() {
cmake_build test-programs
- myctestargs=( --disable-capture --skip-missing-programs --verbose )
+ myctestargs=( --disable-capture --skip-missing-programs=all --verbose )
cmake_src_test
}
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 7c2126e33941..0fca7d964220 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -174,7 +174,7 @@ src_configure() {
src_test() {
cmake_build test-programs
- myctestargs=( --disable-capture --skip-missing-programs --verbose )
+ myctestargs=( --disable-capture --skip-missing-programs=all --verbose )
cmake_src_test
}