summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-06 07:59:36 +0000
committerSam James <sam@gentoo.org>2023-01-06 08:00:01 +0000
commit492cbcf30217641a3625cbf8c53e00c27ae0c369 (patch)
tree08622115ae68ddab9206666bde70a7cdc242696e /net-analyzer
parentdev-util/promu: keyword 0.14.0 for ~loong (diff)
downloadgentoo-492cbcf30217641a3625cbf8c53e00c27ae0c369.tar.gz
gentoo-492cbcf30217641a3625cbf8c53e00c27ae0c369.tar.bz2
gentoo-492cbcf30217641a3625cbf8c53e00c27ae0c369.zip
net-analyzer/macchanger: add USE=split-usr for netifrc
Fixes: 955b84bad9b4a6003e132afd18b557215534eb73 Bug: https://bugs.gentoo.org/889922 Bug: https://bugs.gentoo.org/886121 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/macchanger/macchanger-1.7.0_p5_p4-r2.ebuild (renamed from net-analyzer/macchanger/macchanger-1.7.0_p5_p4-r1.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-analyzer/macchanger/macchanger-1.7.0_p5_p4-r1.ebuild b/net-analyzer/macchanger/macchanger-1.7.0_p5_p4-r2.ebuild
index 2bce7cea0e43..5ec79a35f5a7 100644
--- a/net-analyzer/macchanger/macchanger-1.7.0_p5_p4-r1.ebuild
+++ b/net-analyzer/macchanger/macchanger-1.7.0_p5_p4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Utility for viewing/manipulating the MAC address of network interfaces"
OUI_DATE="20091029" # Generated with tools/IEEE_OUI.py in the source
@@ -14,6 +14,7 @@ SRC_URI="
LICENSE="GPL-2"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
SLOT="0"
+IUSE="split-usr"
PATCHES=(
"${FILESDIR}"/${PN}-1.7.0-fix-caddr_t.patch
@@ -29,7 +30,7 @@ S=${WORKDIR}/${P/_p*}
src_configure() {
# Shared data is installed below /lib, see Bug #57046
econf \
- --bindir="${EPREFIX}/usr/bin" \
+ --bindir="${EPREFIX}/sbin" \
--datadir="${EPREFIX}/lib"
}
@@ -38,5 +39,11 @@ src_install() {
newdoc "${WORKDIR}"/debian/changelog debian.changelog
+ # Can cleanup a while after bug #889922 is fixed
+ if use split-usr ; then
+ dodir /usr/bin
+ dosym -r /sbin/macchanger /usr/bin/macchanger
+ fi
+
dosym ../../lib/macchanger /usr/share/macchanger
}