summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-17 15:56:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-17 16:15:10 +0200
commit4a4d7fd87e76259b2479426fb48f96c2f7802874 (patch)
tree52cbb0de77e7263c3e970e8cdf1c0aea3fea6b09 /net-analyzer
parentnet-libs/libnftnl: Removed old. (diff)
downloadgentoo-4a4d7fd87e76259b2479426fb48f96c2f7802874.tar.gz
gentoo-4a4d7fd87e76259b2479426fb48f96c2f7802874.tar.bz2
gentoo-4a4d7fd87e76259b2479426fb48f96c2f7802874.zip
net-analyzer/prometheus: Version bump to 2.0.0_rc1
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.0.0_rc1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index eed7b14d64f8..17514f887902 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1,3 +1,4 @@
DIST prometheus-1.7.1.tar.gz 5122747 SHA256 209832310f5bef99faef3beaaa95263612a4d0126ca512c4a4c23a8543d3ccf5 SHA512 98a42e95978477530082d7549c29f17b133043d7c233ba3c90b183f06a3f24ee578f8fed75cba476d3c93a22abcccfdbccc94488beb8450a02f260d24165ba26 WHIRLPOOL 8ab473430752336e09b4a0c38fd1117abe21196478d7f2f7e813c27f07c950cc3525d9e9ba32309711c73a1032f3cff27ddc1582d0c4b6c66fe82d5b58675550
DIST prometheus-1.8.0.tar.gz 5194115 SHA256 556247d750b3618b74ccf59669f74a8c0c39e72cdf51cbcc0c0bcc392de195df SHA512 1ac00ddae4753f99f167db9b6efc5fa442918284f59468b8e1c7743e3f946eab895678c87e12a73bf158e3c0bf3df7345dd59855baaabb54fc86f1ae1014192d WHIRLPOOL 9ff6f0dc36f022b2be107ce59878f81b210b196858064655a74e098650abc77d5a0c2afb11dd5ebb242d1e2addbc3a182b1a6ce1f751eed723e3fff3434d319c
DIST prometheus-2.0.0_rc0.tar.gz 5524499 SHA256 e1615defddf3e0a2d32e22ffba5bc3f0f37ff98fac7d4bba2b2c5bb8219f2a22 SHA512 fd382f559ea9a362e2493ea2d317afe600b0ed2299e3d6ef12678658cd62320ad39deec1b4639819b32c4ba34f124792d00dd101632b1c1e4f1123005e20e38d WHIRLPOOL 1d0ed8f35c9f9d5fca8310af21b93d35bad3397fbf88ea0cc2573412c8d58291e521212283abbe5ed4a461e2e1f62f704f96a6070509864972ff3dd1c0eacd67
+DIST prometheus-2.0.0_rc1.tar.gz 5538094 SHA256 5d80280d4f8de0e5c79b02fa2ab9cbe4cf49a287ed268ed85a0f87abd257d226 SHA512 c89509693608a4f00713cb3b9f11b533236898af4a08580ecb4aa5f198d7f568719ddb78225f9d260128288aa7e037d0a0a820f8e42e2db4c7745e2f993fb4fe WHIRLPOOL 1765d9eb600da28e12d2c679a60f050d9557bbf974a53ff86363fb66fb82d64c4b55a85f9aac4c80039c317a88028c794e8387e0db3f0b925b86057d5ae17f7e
diff --git a/net-analyzer/prometheus/prometheus-2.0.0_rc1.ebuild b/net-analyzer/prometheus/prometheus-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..697c41569454
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.0.0_rc1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="5ab8834"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}