summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-03 10:11:15 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-03 10:12:58 +0200
commit4cfa7d280f481fc8bc2a903a449c5a502ea21bdc (patch)
treebc7238772d7d675c13933ad74032bb091eac3e2a /net-analyzer
parentnet-misc/udpcast: Version 20200328 (diff)
downloadgentoo-4cfa7d280f481fc8bc2a903a449c5a502ea21bdc.tar.gz
gentoo-4cfa7d280f481fc8bc2a903a449c5a502ea21bdc.tar.bz2
gentoo-4cfa7d280f481fc8bc2a903a449c5a502ea21bdc.zip
net-analyzer/softflowd: Version 1.0.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/softflowd/Manifest1
-rw-r--r--net-analyzer/softflowd/softflowd-1.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/softflowd/Manifest b/net-analyzer/softflowd/Manifest
index 2b86455b2393..46d9a2da2a2a 100644
--- a/net-analyzer/softflowd/Manifest
+++ b/net-analyzer/softflowd/Manifest
@@ -1 +1,2 @@
DIST softflowd-0.9.9.tar.gz 91939 BLAKE2B 97ef29e5f450f6896d9448359080a64dbe66d4edf031ff7e2b0e8500e9b781b983de6448b8a1d846d4c8c939269004998a090b0b7e7a9367c9c961e0118b8d59 SHA512 4d579c2a087c0f3cd4d2020bcfbddf9dab73254e40678b3509c93bec212bf8b5692f76bfb4e766577e431ff508f0bce0a2cf326184f192e3c5dc8ddf38514dbd
+DIST softflowd-1.0.0.tar.gz 168379 BLAKE2B 97ce677adf8f8278516f25e82db1757ad5fe208fb8923b189698525d58d60c998ea847f29ae91eefed57d7bd1eb42f119a99e46346753539cb3a9584a90eb484 SHA512 01a4f89755c957a495b08c49b572b8b6aa41f5ac7672feb5e31b039fbfab84f3a206b1da95b11de2ec5882123f6ca2387c02efb874ce707c2263bf79b56012fd
diff --git a/net-analyzer/softflowd/softflowd-1.0.0.ebuild b/net-analyzer/softflowd/softflowd-1.0.0.ebuild
new file mode 100644
index 000000000000..6795a9a13ead
--- /dev/null
+++ b/net-analyzer/softflowd/softflowd-1.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="flow-based network traffic analyser capable of Cisco NetFlow data export"
+HOMEPAGE="https://www.mindrot.org/projects/softflowd/"
+SRC_URI="https://github.com/irino/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+PATCHES=(
+# "${FILESDIR}"/${PN}-0.9.9-_GNU_SOURCE.patch
+)
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc collector.pl
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}