summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-09 06:25:44 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-09 06:38:37 -0400
commit586c136ef094cb691b9b5907a4818cffcbd9426b (patch)
tree6643ed19880d8b88046138b1b0f06a2770ee62ef /net-analyzer
parentdev-python/psycopg: Remove old (diff)
downloadgentoo-586c136ef094cb691b9b5907a4818cffcbd9426b.tar.gz
gentoo-586c136ef094cb691b9b5907a4818cffcbd9426b.tar.bz2
gentoo-586c136ef094cb691b9b5907a4818cffcbd9426b.zip
net-analyzer/ipaudit: add 1.1
Beta had several problems to fix for #871282, but this handles all of them. Not really runtime tested though. Closes: https://bugs.gentoo.org/871282 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ipaudit/Manifest1
-rw-r--r--net-analyzer/ipaudit/ipaudit-1.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/ipaudit/Manifest b/net-analyzer/ipaudit/Manifest
index 1d5b03465bf8..646882f18e7d 100644
--- a/net-analyzer/ipaudit/Manifest
+++ b/net-analyzer/ipaudit/Manifest
@@ -1 +1,2 @@
DIST ipaudit-1.0BETA2.tar.gz 135680 BLAKE2B 2a8e7754251c743758d6e0d7008d904a3a237c26a660f5c07661c632dd75ecda6cf3b04253eb76f64c72ed278da00030cf64231bdc4760a6b04df1497f628ec2 SHA512 3a8890821c515aea95762eeb2cc7a649533ff739984c944bcb26acb72434e1f2b453a98365719fce9e062d6262b9d76ac389f149ad2a19361422783bc0b55e09
+DIST ipaudit-1.1.tar.gz 170253 BLAKE2B 6515cab817a35835d5c3eb33dc4d8c9f28a1ceb906854e55c3695fc6ee5d230ad2ae6a6fd59849623e161fe4deb5013f55bdf6effcaaf6ca4d064ded73c148f0 SHA512 5eb1971b454c8c96c02dc260e537a9a627554b7c9d1e269be9de2ffdb5cbfed00272b643de7b15865659cef0db482e4c460f96b1545bcd6c4f208c96d7401ef9
diff --git a/net-analyzer/ipaudit/ipaudit-1.1.ebuild b/net-analyzer/ipaudit/ipaudit-1.1.ebuild
new file mode 100644
index 000000000000..bec71b59b5a9
--- /dev/null
+++ b/net-analyzer/ipaudit/ipaudit-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="IPAudit monitors network activity on a network by host, protocol and port"
+HOMEPAGE="https://ipaudit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib:=
+ mysql? ( dev-db/mysql-connector-c:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with mysql)
+}